Antialiased ZDepth out of Action?

Title says it all… Any standard way of doing this? I have come up with a workaround using the Fog option in the Camera… but would to like to know if there is a less ugly solution.

Render it oversized and scale it down?

You could also try applying a gradient projector looking from way above. I don’t think you can do it isometrically, but it should look correct enough if it’s far away.

1 Like

Projections are a bit more tricky if the camera is moving. Oversized render could work. Camera FOG does the job too, but need to do it in a separated duplicated action node.
Cool cool… was just checking I wasn’t missing a better option. Thank you Andy.


Maybe try the FXAA matchbox shader?

I was wondering how does the “Object Matte” node does the filtering…. thats it. Thank you @Ton .

You need to set Accumulation to All on your Action output. This turns on filtering for all data passes.


Ah ha! That’s the real solution.
Thank you @chrislovesflame

1 Like