Batch: contexts don't update with changes

I started experiencing this a few days ago, and it persists. Suddenly, when looking at downstream comps in Batch (or BFX), the context view does not update with changes to the comp. ie., if I hide a layer in an upstream axis, viewing in the render context, it should disappear. It does not, and the only way to update is to frame advance or frame back. Same in BFX.

It’s the same behavior with non-Action nodes, like a blur node in Batch, if I bypass it or change it’s values, the context view only updates after moving a frame.
In 2-up view, my blur node result is on the left. It updates as it should. Downstream render context does not update at the same time, only if I frame advance.

What is strange is that after relaunching Flame or making a clean batch, etc., sometimes it works for maybe a couple of minutes, then it starts happening again.

I’ve tried a fresh user, I’ve tried different projects where I never saw this, I’ve tried with different footage, rebooted multiple times, etc. No dice. It makes it really difficult to work, of course.

2024.1.1, Linux

Any thoughts on this?

1 Like

Do you have any mux slips or anything that is changing the timing :thinking:

That always messes up my downstream context view.

Other than that I haven’t seen this behavior in Flame 2023.3.1

Nope, no Muxes with time offsets.

Any pesky yellow cache buttons accidentally pressed on any nodes?

They have a nasty habit of not releasing their cache when things are updated.

Nope, flushed & deactivated all caches.

I get this periodically on large batches and have done for several versions.

Hey !
Had this issues in the past.
From what I can remember it was coming from the paint node ( + plus your current flame version is very buggy on 6k, Can result in huge crash if you paint out the border viewer ).
You should try going to the last 2024 release, works very weel and never had this issues again.
Hope this can help you :slight_smile:

I bet for some paint node too. I have to disconnect/reconnect it sometimes to force refresh when I have similar issues.

Thanks everyone. Surprisingly it wasn’t paint this time, but seems to have been caused by an Action at the end of the chain which had been set to bypass. Removing it entirely seems to have done the trick.