Did filtering change for broadcast monitor?

Maybe it’s me, but did filtering change when watching a sequence on the broadcast monitor in the latest flame software?
A 1920x1080 sequence shows correctly. But all other fun social formats or 3K, 4K scales correctly to fit the monitor, but feels like it’s using a ‘nearest’ filtering instead of something smoother. All text/logo’s looks jagged. I don’t remember noticing that in the past flame releases… Or is it some hidden setting?

Is filtering turned off in the Viewing Settings and Scale to Fit Monitor enabled? This will cause jaggies. Do you have Scale to Fit Monitor disabled? If so, it may be the monitor doing the rescaling and it is my experience that when left to themselves, monitors suck at rescaling.

No, it didnt’ change. 9 times out of 10 when this kinda stuff happens its because we have new users and forgot about a setting somewhere.

That may well be (I always thought it was linear) but my point was that if the filtering is turned of in the viewing options menu, it effects the picture in the broadcast monitor as well if the broadcast monitor is set to Scale to Fit.

The weird thing is if attach a resize node in Batch (for example a resize to 1080x1920) my broadcast is looking fine.
But as soon as I put that in a sequence (rendered out or as BFX, or even open the BFX as a clip inside batch) it looks very jaggy on the broadcast.
Filtering on/off in Viewing settings is not showing me any difference. I don’t understand where this comes from. I tried different users as well.

1 Like

Is your Player set to Interlaced? Or Sequence? Check your Blackmagic and or AJA settings too.

I just now tried the same thing in 2022.1 and there it shows correctly.
Only in 2022.2 there is the filtering issue.


It’s very unlikely this has changed in flame. Every once in a while Use Ratio is turned off in the player and caused me similar issues in the past. That or in the player inhve mistakenly turned in add 3:2.

Try those. If not I may be able to help troubleshoot this on Discord. Can you share screens on discord?

This problem has been fixed in the 2022.3 Update version.

Broadcast monitor filtering is now enabled throughout the application when the image is resized to fit the broadcast’s resolution. However, it is possible to disable it by selecting the Broadcast Toolbar (when Viewport Monitoring is disabled in Preferences/Broadcast Monitor) and turning off Filtering in the View menu. This way you can disable Broadcast Filtering in all tabs except Timeline.

1 Like

Excuse my ignorance but what is broadcast filtering?

The best way to visualize it is by doing this:
1.Open a clip in the Player
2. Zoom in quite a lot
3. Enable/Disable the Filtering button in the Viewing Settings panel.

There was no longer any filtering applied when the image was scaled to fit the monitor in the broadcast.

1 Like

Thanks Fred