External framestore not found after reboot

I’m temporarily using an external SSD as framestore but whenever I restart the mac (Mac pro 2019) flame (2023) says there’s no framestore in the box where you select project, user etc. The SSD is mounted before I open flame.
In the “Media Storage” tab of the setup I can see the four framestores I’ve set up (due to this issue) but when I run sw_df I only see one (the last one I created).

At the moment I archive every day before leaving in case of a power outage or something else that causes the computer to restart but there is one project that I didn’t have a chance to archive.

Any tips on how to get access to the other framestores on the SSD are appreciated! I’d really like to archive out all projects.

Sorry if this is answered somewhere else, I searched here and on google but could not find anything to get it working for me.

Cheers!

Hi @Rajdarn
Did you solve this issue? I’m getting a similar one on my mac
Thanks

Hi!
No, not yet. I’m still looking but I haven’t had too much time to research. I’ll keep you posted if I figure something out, would you do the same please?

Cheers!

1 Like

I have this issue like once a week. Here’s how I fix it… use at your own risk.

Go into a terminal and type ‘cd /Volumes’ then press enter.

Type ‘ls -al’ and press enter. This will give you a list of the available Volumes.

On my Mac, I see two listings for my external SSD, “Pebbles” and “Pebbles 1”. It’s like Mac OS doesn’t see the SSD for a time, or doesn’t unmount it and creates a new mount point called “Pebbles 1”. In my case, I have to remove “Pebbles” and rename “Pebbles 1” to “Pebbles”

That solves the problem for me. I am doing something very destructive, so please be careful. When I first diagnosed this problem I renamed “Pebbles” “Pebbles_temp” rather than delete it. Def try renaming first.

Hope this helps!

Hi Andy,
Thanks for your reply!
So today I have some free time to try your solution but I have a question:
How are you renaming “Pebbles” to “Pebbles_temp”?

I can right click the ssd and rename it from “Pebbles 1” to whatever I want but first I want to rename “Pebbles” to “Pebbles_temp”. However, this cannot be done by right clicking the ssd, right? Are you using a terminal command to rename the partitions (or mount points or whatever they are) that shows up when listing volumes using ls -al?

Thanks for your help with this!

My pleasure!

I’m doing it in the terminal. I think that MacOS tries to “help” with the icons by keeping the name the same.

Open a terminal and type cd /Volumes

Then do ls -al

That’ll show you what the volume names are.

Hi!
I’m with you so far, I have the volumes listed in the terminal but what I don’t get is the next step. You remove and rename the volumes some where but I don’t really understand where and how :smile:
Could you clarify that part for me?
Sorry, I’m not really a mac guy.

Ah, sorry.

The next bit is:

sudo mv Pebbles Pebbles_temp

Then

sudo mv Pebbles\ 1\ Pebbles

That should do it!

Awesome, thanks!
Just so I understand what I’m doing here:
sudo mv Pebbles Pebbles_temp ← here I’m renaming Pebbles to Pebbles_temp
sudo mv Pebbles\ 1\ Pebbles ← here I’m renaming Pebbles 1 to Pebbles with \ so the terminal ignores the " " whitespace and wont interpret the “1” as a command (in this case what we want Pebbles to be renamed to)?

Did I get it close enough?
Thanks Andy!

You got it :fire:

That’s what fixes this issue for me with my external SSD.

Hey look at me, I’m a mac guy! :smile:
I’ll give it a shot and report back.

Thanks for all the help Andy!

1 Like

:+1:t2::+1:t2::+1:t2::+1:t2:

Hi again.
So I tried your trick, Andy, with a small modification so my command was:
sudo mv Pebbles\ 1 Pebbles (notice the absence of the second \ after the 1)
using the second \ did not work for me for some reason.

After renaming my mount point I started flame and under workspace i got “No project selected” and under project I got “Click the New button to create a Project”.

I have a total of 4 mount points (so equivalent of Pebbles, Pebbles 1, Pebbles 2 etc) and tried to rename most of the with the same results so It seems that it’s not working for me. I also tried to restart S+W using the System monitor and after that I got my latest mount point again even though it is renamed to Name_temp.

Is there something I missed? Do I need to do something else after running the mv-commands? Is there something else I can try maybe?

Any ideas would be appreciated.
Cheers

Bummer… Sorry that it didn’t work for you. I guess maybe the only thing to try is a reboot if you haven’t tried one yet.

Also, try loading up the flame set up application. I believe it’s under the storage tab… You can select what the active frame store is.

Yeah, I’m a bit hesitant to reboot since it will generate an additional mount point for me but I’ll try it as a last resort.
Do you know how to set the active frame store in the setup? All my four fs show up in the list but I don’t know how to tell it which one to use.

1 Like

FYI this is a very common thing on the Mac side of things…some Google Fu returns…

And this was asked 8 years ago…

2 Likes

Happy days, there is some progress!
So I restarted the computer and started flame - no framestore, no surprise. I did a ls -al in /Volumes and noticed that my SSD mount points didn’t have correct permissions. After bowing my head in shame for a bit I followed step 3 from this guide:

and wrote: sudo chmod 777 /media_storage_path

I started up flame and it found a framestore! So now I’m just archiving out all projects I can access so I can bring them into my new “real” framestore. After that I’ll try to rename some volumes and se if I have better luck with them.

PS. This is meant more as a log for people who might have the same problem in the future.