Flame wont launch - M2 max / Rosetta issue?

Hi there team,

I’m having technical issues over here and Autodesk support has been unable to help.
I recently bought a MacBook Pro M2 max laptop. I installed Flame 2024 a few weeks back no worries. When I first launched the software it said it needed to install Rosetta to work (I thought it worked natively on M series CPUs now?). I installed Rosetta and everything seemed to be fine. Ran a couple of tests, all seemed to work well.

I didn’t run Flame for the last week or so and now it won’t even open. I opened a support ticket with Autodesk. Had a live chat with someone there who wasn’t able to resolve it. They uninstalled Flame and now the installer wont even run. In the console it says:

Termination Reason: ROSETTA 0

The final line from Autodesk support was that I need to resolve this with Apple.
I’m not overly technical but I kind of feel like Autodesk has just dumped me in the ‘too hard’ basket.
Does anyone have any insight into this?

Two ideas (which ADSK support may have already gone through with you):

When you right-click on the Flame App to ‘Get Info’, there’s a checkbox whether to run an app in Rosetta mode or native. See if that checkbox is checked, and try it the other way?

Second thing - you said you were prompted to install Rosetta (I just had the same thing on a new system last week - it seems in MacOS Monterey Rosetta was installed by default, but in Ventura it’s optional). There may be a way to see if it’s still installed or maybe somehow got removed?

My guess somehow that checkbox got unchecked (or the default changed). Now it’s trying to run in native mode and stumbling over something.

ADSK support isn’t entirely wrong to point you at Apple. If there’s a problem with Rosetta on your system, that is an Apple ecosystem issue. ADSK may know a little bit about it, but it’s not their domain. I agree though that becoming a beach ball between two big tech company’s support teams can be a super frustrating thing. Been there way too many times.

1 Like

I do not have all the facts of the case, however I would suggest you try to open a proper case with support (Help using my product when prompted). The Flame product specialists do not have chat support, you likely had a case with an installation and licensing specialists.

Thanks @allklier This was the tip in the right direction that I needed.
I tried forcing some other apps to run in Rosetta using your cmd + i trick and no luck. It seems that somehow Rosetta damaged or not working. I found this video on how to install it manually from the terminal:

It all went smoothly and from there I was able to re-install Flame.
Many thanks for your help!