Keyboard

In all the excitement i thought i would treat myself to a new keyboard even the old clunky one works fine.
the old one is a logitech k200, big and clunky, and new is Logitech MXKeys S. looks really cool and modern, but my flame hot keys do not work with the new now ?? any hints for me ??

I fell into the same trap with my Keychron. I never got it worked out in a satisfactory matter. I moved it to may mac and put my old Logitek G610 back on the Linux. There are ways to fix it but I found them way to cumbersome. It was like making 3 left turns to turn right.

that sounds about right. as we say at home, “fancy new keyboards are all mouth, no trousers”

I’m ok with my keychron. I had to move primary/secondary/blend to f9/10/11 which was the most annoying. Took some new muscle memory

I’m using a Das Keyboard Pro6 on Mac and Linux. Kinda just works and it allows me to type aggressively… at least that’s how it sounds.

tough typing

1 Like

I think there were just a few that didn’t work, but they were ones I use a lot and I am unwilling to move them around. I might try the Das Keyboard Pro6.

yes, the layout of the 2 keyboards is identical, same manufacturer , completely different functionality .

I use a Keychron k10 pro. I love it, but it did require some elbow grease to get the function keys working (f13, f14, f15). I think it’s the same one @ytf bought. It would be great if things worked out of the box!

the timeline navigation keys are different , and odd things like copying just one frame from a clip the instruction is gone. exhaisting ti try and reassign everything

Are you down for a screen share on discord? If not, I can type things out

No worries! Map all layers of your function keys to print, scroll, pause.

Animation

It’s the QMK/VIA software used to re-map the keys on the Keychron keyboard. By default the function keys were mapped as media keys so Flame did not read them well. To avoid confusion, I remapped all of the layers to print, screen, lock, and suddenly Flame could read it the inputs. No need to change any keyboard settings in Flame.

You lucky ducky!

Are you on Rocky or CentOS?