Problem with F13 F14 F15 keys on Mac using PC keyboard

So here is my real problem. The poll is just an amusing aside.

I am always using a PC keyboard for Flame on a Mac. No problem for me when I am working locally on an iMac. During lockdown I had an iMac at home and my PC keyboard gave me comfort and behaved in exactly the same way the Linux boxes at the office did (love the fact we don’t need to relearn any hotkeys on different operating systems).

We started to roll out Teradici and we got a new Mac Pro. Everything seemed to be fine until it came to a conform and I found I couldn’t toggle from Primary to Secondary using PrtScn (F13) and ScrollLock (F14).

This only seemed to effect the Mac Pro and I was happy to blame the quirks of Teradici and just live with doing the switch manually :roll_eyes: When we came back to the office the problem persisted even without Teradici. I compared the keyboard settings on the iMac and the Mac Pro. They are both identical but the PC keyboard doesn’t see F13, F14 and F15 keys on the MacPro :angry:

I found that the problem went away when I plugged in and used a Mac keyboard :man_shrugging:

Has anyone experienced this quirk before and know of a fix I can use. Ideally one that doesn’t involve remapping the hotkeys.


Screen Shot 2022-02-10 at 10.59.27 AM

1 Like

@PlaceYourBetts that keyboard in Flame doesnt really do what you think it does. If I were a betting man, I’d bet that at the OS level on the Mac side your F13 and F14 are set to something stupid, like Display Brightness Increase and Decrease, respectively.

Head on over to System Preferences, Keyboard, Display, and make sure the Decrease display brightness and Increase display brightness are disabled.

Most of the time these things happen its a conflict at the OS level.

1 Like

I really thought I had all of these turned off.

Thanks @randy
Screen Shot 2022-02-10 at 1.06.48 PM

2 Likes

Excited Come On GIF by MLB

2 Likes

I would also like to thank you for this @randy.

1 Like

I’ve had keyboard issues like this on and off over the last two years. Definitely had this one the first time I used RGS. These are a couple of tools I picked up along the way to help diagnose when I’m having input problems.

If you’re connecting remotely to a linux box you can use this command on the linux side to see what input it is receiving from your keyboard. If you run this command in a terminal it will create a small box. If you hover your mouse above this box and then press the key that is giving you trouble it will print the output into the terminal.


xev | grep -A2 --line-buffered '^KeyRelease' \
    | sed -n '/keycode /s/^.*keycode \([0-9]*\).* (.*, \(.*\)).*$/\1 \2/p'

This link explains it better.

This covers it in more depth.

On the mac side I just use this website. You could presumably also use it on the linux side if your box has internet access.

If your function keys are mapped to specific mac shortcuts they won’t generate any input for the keyboard checker.

Also sometimes on the linux side the Print Screen button will be mapped to a screenshot shortcut. This can usually be disabled in the settings under keyboard shortcuts. This is what it looks like in KDE.

Hope thats helpful for someone else in the future.

1 Like

Ok just so you all know that I am not going crazy.

I am back at home now using Teradici. The problem has returned and the Display option is no longer there!

PlaceYourBetts –

Have you tried Karabiner Elements?

https://techpp.com/2021/06/14/karabiner-elements-mac-keyboard-customizer/

1 Like

I will take a look in the morning. Thanks @chris

Teradici wasn’t really designed for complex softwares like flame that is so Hotkeys dependent.

You have to setup USB Bridge mode on your Mac to basically “give” the entirety of your local keyboard to your Teradici host machine. This is the only way over Teradici to have access to all of your Flame Hotkeys.

Do you see USB Devices in the drop down menu of your Teradici PCoIP Software Client?

PlaceYourBetts –

The last time I did a Teradici job (from my Mac client) the facility’s tech folk asked if, in the Mac’s Keyboard Preferences pane, could I see the checkbox-option, “Use F1, F2, etc. keys as standard function keys”. I know that option well but for some reason that option was nowhere to be found in my settings.

Once I downloaded Karabiner-Elements (it’s free) I was able to restore the option of “Use F1, F2, etc. keys as standard function keys”, although in Karabiner, not in the Keyboard pref pane.

If randy’s suggestion with USB Bridge doesn’t solve your issue let me know if you want more details on Karabiner and I’ll add them on here.

1 Like



This is how you setup Wacom pen pressure sensitivity and full Flame hotkey support from Windows and Mac Teradici PCoIP Software Clients. If your F13/F14/F15 hotkeys don’t work, it because of this, not because of any other Mac OS setting or Karabiner or Mac or Windows preferences.

Basically, the Teradic PCoIP Software Client needs a bunch of USB and secret sauce root-level schtuff to be able to give the entirety of the device to your Host machine. On Windows, its super easy, you just install the PCoIP Software Client and you have automatically gain access to the USB Devices menu where you can assign local machines to, quite literally, “become remote devices.” Because Windows.

On the Mac, you don’t even know its an option because you not only have to grant it permission upon install, it won’t offer you the choice to gain permission to assign your USB devices to your Host because…dun dun dun…csrutil! ARGH!!! You’ll need to boot into recover mode, open a terminal, type ‘csrutil disable’ and reboot. (Apple csrutil disable procedure here) Then upon reboot, reinstall the Teradici PCoIP Software Client, and at the end you will receive a little pop up asking you something something USB Permission something something. Approve that. Then and only then will USB Devices become visible for you to choose.

Now, the hard part is, once you assign a local device over to your host, IT DON’T WORK ON YOUR LOCAL DEVICE NO MORE! In other words, assign your mouse to your host? Great, now your mouse won’t do a darn thing except within the PCoIP Software Client application. You won’t be able to use your mouse to click on any application that is on your client machine, only your host. So, you should have an extra keyboard and an extra mouse available…one set for Host control, one set for client control.

The OTHER fecking frustrating thing about all of this, is the Teradici will tell you Mac Big Sur isn’t supported because somethign something security risk something something csrutil something something. It works. They just won’t risk the legal mumbo jumbo on having you bypass security procedures to use their product. Which, I get. Kinda. Not really. Oh well.

At the end of the day? Seriously. If you are going to spend any extended length of time on a Teradici, do yourself a favor and spend $600 on a Tiny P330/340 or Intel NUC or anything with a tiny Nvidia card in it to dual boot Windows and Ubuntu so you can have easy Teradici access and HP Z Remote Boost with pen pressure sensitivity on the Ubuntu side.

What a time to be a Flame Artist.TM

1 Like

Great details, Randy!

For someone that doesn’t want to add a NUC for doing one or two jobs per year with a Teradici client, maybe making a separate Mac user for these Teradici sessions could be another option?

1 Like

I don’t see the USB option on my PC client. I will have a look at my Mac Client tomorrow.

@abeis Can we test the Intel NUC as a client?

I would really love to crack the pen sensitivity.

1 Like

This sounds like more of Host config problem.

Does RGS / ZBoost have this option as well?

For completeness’ sake, the concept of using Karabiner on macOS to solve FKey problems was made to me personally from one of the Toms at Gunpowder.

Thanks @chris

You can’t beat a free bit of software with the promise of fixing all of your woah.

Would you mind elaborating on Karabiner-EventViewer. It isnt the most intuitive bit of free software.

Thanks in advance :+1:

PlaceYourBetts –

Download and install Karabiner Elements from this link:
https://karabiner-elements.pqrs.org

Once you do that, you’ll see a new menu bar icon that looks like a segmented square. There are interesting attributes you can set via that icon, but what you should do first is to open your /Applications folder and launch Karabiner-Elements.app.

Once that launches, open the app’s preferences and select the “Function Keys” tab.

You’ll then see the old-school option to use your FKey buttons as standard function keys:

2 Likes

Regarding that screenshot, when I was initially setting up Karabiner-Elements I manually assigned F1 - F4 as F1-F4 before I realized that checking the “Use all F1, F2, etc. keys…” option overrides all of those drop-down key assignments.

Once the check box is… ah… checked, there should be no need to make any further changes.