Logitech keyboard no working properly on mac


I’m new to flame on mac and the my logitech keyboard is no longer behaving like it should.

The space bar no longer pans the view finder.
Shift tab doesn’t bring up the app switcher.
f1 - f4 doesn’t work
etc, etc

I did all the standards - use f1, f2 etc keys as standard function keys, turned off application windows in mission control, i changed the keyboard type, etc

is there something obvious i"m missing?

Any help is appreciated.

The only two problem solvin things might be a reboot and a new user :man_shrugging:

I also had this problem once, I use a HP keyboard, I really turned off all hooks in the mission control except for the F1, F2 standard function.
As keyboard type I use ABC - Extended.
OS version Ventura 13.5.2
I hope I could help
Screenshot 2023-10-18 at 09.45.50

Yes to having seen the function keys not working the way they should but the space (pan) :thinking:.

Does the space work for anything in Flame? Can you type a space in the text module? Does is pause playback?

The space bar doesn’t seem to work at all. I’ve rebooted and tried a different user.

Sounds like either a driver issue or your keyboard is kaput. Try it on another machine.

1 Like

I dont believe shift + tab brings up the app switcher… its cmd + tab.

Is this the logitech mx? You might have to change it from windows to mac mode.

no its not an mx. just a basic k120.

This might be the most obvious :point_up:reason

Works fine on my Linux system plus I’m having the problem that with both Logitech and Apple keyboard.


Thanks everyone for the suggestions. Had to reinstall the OS and reinstall flame to fix it. Nothing’s every easy!

1 Like

Hey Shauna! I also had a problem with my HP keyboard when first putting my MacStudio system together.
There’s the ‘change keyboard type’ button in System Settings/Keyboard that identifies the physical keyboard that you have by you pressing buttons that it asks you for, so that’s worth checking. Then there’s the ‘Text Input’ section in there as well. I had my keyboard set to ‘US International PC’ (which I thought sounded right, cos it’s one of the HP keyboards that we used at Jogger), but you actually needed just plain ole ‘US’.
Looks like you fixed it now anyway, but someone might be searching one day and find this useful.

Hey Andy. Thanks for the suggestion. Nice to hear from you. Hope all is well. I hear you are back in the UK. You’re gonna miss Cali come this winter but I bet its nice to be home!

Right on all counts!