Kill Flame alias in centos8


kf command to kill flame is not working anymore in centos 8 (at least in my system) . I checked my .rc files of my user. I have one .cshrc and one .bashrc. .cshrc has several aliases created by autodesk. “flame” and “kf”. .bashrc is the default file of centos 8 , if I’m not wrong.

I copied kf alias definitions to bashrc just in case. I’m not sure what is the right file. Anyway, kf still not working.

I played with this config files time ago, to add “flame” alias to .bashrc to launh flame as usual (alias flame=´path to flame binary’

I’m not sure if I mess this files. I wonder if anyone miss kf command also or if I have some wrong in my system of if an specifical issue of centos 8.


1 Like

Find Flame’s PID by running a top command in a terminal. That’s typically a 4-5 digit number, second from the left column if my memory serves me right.

Then, execute a

kill -9 <PID>

and bob’s your uncle.

OR if you open up the ServiceMonitor app by typing


in a terminal then I believe there is a page to select called Troubleshooting? and has a Kill Flame button.

1 Like

Add to ~/.bashrc (.bashrc in your own home directory):

alias kf='kill -9 `pgrep flame`'

Note the backquotes around pgrep flame, not apostrophes.

Starting flame is a little trickier, since you’ll have to edit it for every new version you install, but basically:

alias flame='/opt/Autodesk/flame_WHATEVERVERSION/bin/startApplication'

should work (edited – I was fighting with Discourse markup with the backquotes and missed the rest of the syntax being messed up :smiley:)


Sure! But I prefer use the old and dear “kf” . And I don’t understand why this alias stop working in centos 8.

Thanks. I’ll try next monday. No problem with alias for flame. I use to edit it when a new version is installed. The definition of kf installed by flame is pretty longer, with long cut/grep/awk arguments. I tried to findout a bit how it works, but my patience with this kind of linux-things is limited.

1 Like

Just looking at the .cshrc file I see included with flame now, the main command they used was killall -v -s9 flame which won’t really work anymore because it won’t match the process name. The rest of the command using multiple 'grep’s and ‘cut’ looks like it was trying to find and kill “tee” processes, which is used to mirror the output of a program to the console as well as a separate logfile. But that must be from versions passed, as I’ve never noticed the flame launch scripts ever use tee.

In my version I’m just calling pgrep to find the process ID of flame, which is fed to kill to kill it.

Finally, it worked!! thanks ! ManChicken :upside_down_face:

1 Like