Logik Matchbook installation / machbox icons are gone in the BFX & Batch tab

After moving the Z8 from CentOS 7.6 to Rocky 8.5 I was reinstalling the Logik Matchbook.
Installation worked fine but after starting Flame I noticed that the Matchbox tab in BFX and Batch are completly empty. The Matchbox’s are still working I can load them with right click but I didn’t find a solution the get the icons back…having a chat with Autodesk support and checking the Matchbox path again looks like the only solution would be to reinstall Flame and not install the Logik’s again.
Any idea on that?

Your answer may be here.

Autodesk support told me, that after uinstalling Flame you have to manually delete the folder
and then reinstall Flame

What could also work is to set the Matchbox shader path to a previous installed version…I think support even tested that…
As I have a complete new installation with 2023.3 I wasn’t able to test that…

I am also seeing this on my end on Centos Flame 2023.3. The matchbox bin doesn’t have the shader icons but using the right click you can add them and they work. Not sure if anyone found a solution to this yet?

I wrote Julik about the issue…
In the meantime Mark from Autodesk made this available:

Thanks! I’ll first try to just move the path to an older version. I don’t feel like re-installing at the moment.

Me neither…

Roger Koller

Owner / Visual Effects Artist

RoDo Works AG

Plattenstrasse 44

8032 Zürich

Phone +41 44 521 25 40

Mobile +41 79 308 6411


This might be related to some matchboxes from Logik that seem to freak Flame out. Try downloading them again then removing tpo_cas and then restart Flame. That fixed it for us.

Fixed it here as well!
Cool, thanks!

@tpo seems like your new matchbox shader is causing some grief :arrow_up:

1 Like

Feel free to remove from the Website guys, i dont see that option on my end otherwise i would have done by now.

Stills seams strange to me that one matchbox can affect all others or node UI on Flame. Super strange.
I dont use node-bin for matchbox anyways, might be that i didnt verify.
Matchbox itself has been working just fine

1 Like

I think it’s the missing xml file throwing the system off

awesome! That’s working here as well.

Writing this solution here too for future reference:

As a small update to this I managed to figure out how to upload an .xml to tpo_cas so for all future downloads of the Logik matchbox shaders, this shader shouldn’t create the empty matchbox bin anymore.

1 Like