Matchbox nodes are gone in Node Bin and also in FX Nodes

Hi guys,

For some unknown reason, I have lost my matchbox nodes either in the Node Bin and the Fx Node Bin. I tried to set the directory through the preferences menu, where there’s an option to set the path, but although they are all there, they are not being loaded.

As I couldn’t reload them I thought, ok, let’s reinstall flame, but it detects the version is already installed and it does not go ahead.

Any idea or suggestion on how to see again the nodes in the bins?

Thanks

2 Likes

Same here. I’m on flame_2023.0.1

I’m on 2023.1 linux

Hmm. Seems to be working here. Are you sure it’s set to the right place? Like /opt/Autodesk/presets/2023.1/matchbox/shaders ? Might also try hitting ‘Reset Bin’ on the Matchbox bin tab.

Same here for us on 2023.1. They are still sitting in the /matchbox/shaders directory, so you can pull out a Matchbox node from the All Nodes bin and load one from there, but it is annoying. Re-setting the bins doesn’t work either.

Can you try to delete the file /opt/Autodesk/project/your_project_name/status/mxCache.xml before starting the application and see if it make any difference.

Could it have anything to do with this little selector?

This happened to me after “installing” a matchbox. Once it had been removed the matchbox tabs repopulated after a restart.

2 Likes

@alex_h Thanks! your suggestion worked for me. I added crok_aurora_CFX.glsl a while back.
Removing it solve the problem.

2 Likes

This worked!!! Such weird behavior.

2 Likes

Hi Francesco, I have this same bug. Where had you added & removed the matchbox? Was this in batch or in a system folder?

I also had corrupt proxies of the LOGIK Matchbox but these sorted themselves out after a couple of restarts.

The latest addition seems to have brought this back. We lost the node bin and ability to search today. The shader is tpo_cas.glsl and it doesn’t have a XML with it. Unsure if that’s what’s causing it.

@tpo Is this yours?

I’ve had the same issue today after installing the tpo_cas.glsl shader. Deleting the Logik shaders and restarting hasn’t cleared the issue

To fix the issue we just removed from the matchbox folder the new additions, and voila…back to normal. You still can use it but copy it to a different folder and to use the “new” matchboxes, you must do it by browsing.

Hey Kyle! yes that is mine!
That is a straightforward shader conversion only, nothing that is calling other matches or flame’s bin ui that could affect this. Strange…there is no xml yeah since worked without it so i’ve just uploaded to website.

Attached the my whole code for that
cas_code.pdf (25.6 KB)

Below is the official Autodesk fix for an empty Matchbox Node bin. It worked for me without having to do the last stage of reinstalling flame.

1 Like