Logik portal no stable diffusion

I’m trying to install stable diffusion on my linux flamne, (2023.3.2 on centos 7), but its not showing up in the list of scripts available.


Yeah i cant see it on their either.

We will need more info. What does the terminal say upon launch?

Also, try and take every other python script out of the op, auto desk shared python folder and try that and see what happens.

Hi Randy. Its actually just not in the portal for me at all.

If I scroll down the list of logik portal updates, I see an entry 08.25.23 that say Stable diffusion v0.1.4 and another below it, however in the top right pane, (portal python scripts) it’s not showing.
It was there a couple of weeks ago when I installed it to my mac, but it’s just not showing anymore.

Hey guys

Sorry I haven’t responded to this. I’ve been buried in work the past couple of weeks.

I took that script off the portal. Based on the problems you guys were having it looks like there are a few things I still need to fix to get it to install properly. I’m going to be working on that this week and hopefully have a new version for you guys to try out soon.



@MikeV thank you! Really appreciate it

Thanks for the clarification Mike.

I just added a new version of the Stable Diffusion script(v0.1.5) to the Logik Portal. For the time being it will only work with M1/M2 Macs running 2024.1. There are some issues I still need to figure out on the linux end to get it working.

When running it for the first time on the Mac it will install a couple python packages it needs. After that is done run the script again and it should start downloading and installing Stable Diffusion. This will take a bit depending on your internet speed. After it’s done with that the script should hopefully start up on it’s own.

If anyone gets around to trying it, let me know how it goes.


Hi Mike,

I hope all is well ! I’ve been running some tests using Flame 2024.1 on my M1 Studio and I’ve encountered a few issues that I wanted to bring to your attention.

Installation Loop: The script appears to be stuck, looping during the first stage of the installation. I’ve found that closing and reopening Flame allows me to proceed with the “Stable Diffusion” installation. Alternatively, a re-scan of Python hooks might resolve the issue.
Image-to-Image Module: I attempted to use in-painting with a mask and also tried adding a prompt. However, pressing the “Submit” button doesn’t produce any results. I’ve tried this with both QHD and 740x740 resolutions, but to no avail.
Upscaling: When trying to upscale an image by a factor of two, the status shows “hallucinating”
Text-to-Image Module: I wrote a sentence and requested a 512x512 image, but again, the system is stuck on “hallucinating”

I haven’t been able to receive any output from Stable Diffusion, which leads me to believe that I might be missing a step or perhaps doing something incorrectly.

Hey Jerem

Thanks for the feedback. Is this all using the latest version I put up on the Logik Portal last night? v0.1.5?



Yes, it’s the last version.

Does a shell open when you run the script that loads stable diffusion? Does a progress window open? Are you getting any errors in the Flame terminal?



Hey Mike,

I record my screen and paste log.

On this news test with a file size of 512*512 the resize module work. Maybe my file was too large yesterday.
Still having issue with the image to image module. Pressing submit is not writting any log.
Let me know if i’m missing a step.