Mastergrade being buggy

Hi All,

Im using the mastergrade node with some key frames in the curves tab. when i render through the node its as if there is no grade or keyframes. Also it has this error messge ‘master grade needs input1’.the same behavior happens if i have a matte or not running into the node.

Is anyone else experiencing crappy behavior from the mastergrade node?

OS and version? But the error message makes me think that your batch setup may be corrupted. Did you try starting from scratch in a clean project?

Are you using a MasterGrade node in Batch, or an Image node, or a Timeline effect?

hi @Sinan its 2024 on linux not sure the OS. i have now tried in another project, same error message, its as if the node is doing nothing.

Hi @bryanb using the node in batch.

Can you paste a screenshot of your schematic, batch and image. Maybe there’s something wrong with the selectives? Because, I tried it on Linux 2024.2 and all the curves are working OK.

What’s your VRAM saying?

Hi @marios yeah thats fine, first thing i checked!

Hi @Epoulson

Autokey? or try getting the same look using in your primarys see if does the same thing?

My bad, I tested the Image node, but you’re using the MasterGrade node.

ive tried a few combinations, it displays my animated grade when I scrub through soon as i render no dice. ive fixed with a colour correct node but master grade aways seem to do weird shit for me when key frames are introduced.

I use it loads no problems, … did you get the same issue using your primaries?

seems to work fine in primaries!

must be bug then, report it

1 Like

I hardly use curves anymore, …may be thats why,…?

Seems odd. I have tested Mastergrade in batch with keyframes in curves and it has no problem.

When you get this error - does it do that on all frames? Maybe the media is short or long, or something upstream doesn’t render? I change perferences to ‘no media’ but still couldn’t make it fail.

Also you say ‘render’ - is only the render bad, or does it also look bad in the UI? Can you trace back where the last time is that you get good image?

yea I didnt have time before but I did a quick test and it worked for me too (on Mac), so must be something else…,maybe,…a linux ting, or Nvidia card?

hi @allklier its just the cached media - mastergrade node - render node. looks fine and animates in the ui when i render its as if the node has been bypassed.

maybe, i have has issues with mastergrade and keyframes in the curves too on mac too but that was on 2023. its just abit annoying as i like using this node but it seem a bit flakey.