Microsoft Teams color issue on Linux trying to share flame

I used this just fine at MPC, but now trying to use the microsoft teams sharing my Linux flame for my team or to the clients i am running in weird color issues just on the share screen. i undertand this is more if a teams issue but maybe one of you have run into similar issues or have a recommendation in trying another way to share my screen.?
I do have a 4k monitor but dropping it to 1920x 1080 doesn’t seem to fix the issue. Weirdly when i share my linux screen, all is totally fine UNTIL i try and share all my screens, the only way to share the flame screen as the flame doesntly allow me to share it separately? not sure why!
Oh the color issue is that all the reds are dropped! like its deleting the red channel… or it goes completly Psydelic.
How do you all share for review?

My weapon of choice is YouTube live, then another link for the clients and me. Delay is just under 2 seconds and perfect synced audio to picture


I have been using slack with a lot of companies and that seems to work really well

thank you! ill explore both options

I am trying Slack, and when i screen share, i get the same issue! my share is all green! i can see picture but it cuts out the red channel of color so i get a green cast over everything. So it must be something in the linux/centos side of things. Not a flame issue or a teams/Slack issue… i cant seem to find anyone on google having the same problem…

I’ve got my zoom camera as the output of Flame and I screen share at the same time. The camera feed is good for realtime and not for colour and the screen share of flame is pretty good for colour. Clients can see me work simultaneously looking at the full screen output.

Ok i finally found a solution to my issue regarding weird colors in all screen sharing apps on my flame box…
its bit depth. My monitor and GFX card is giving me 30 bits, and its too high for these screen sharing apps. It took me a while to find it but if i dropped the bit depth of my GFX card output to 24 everything works perfectly! i had to change the xorg.cfg file of course and using this command tells you what is being displayed:

xwininfo -root | grep Depth

problem solved but so hard to find the answer to this query! I tried Nomachine, teams, Slack, Zoom… it was nomachine that made me realise what it was,.

1 Like