Motion vector track previewing but not rendering

I’ve been given a series of live action splash passes to build a multi layer comp from. Some beauty work is required so I generated a motion vector pass with motion analysis, rendered into a BFX to inprove interactivity and am using it to warp my painted frame and matte to cover studio lights in the splash.

Jogging through in batch it looks perfect. No motion blur is applied to the action btw. However, when I render the batch (simplified at this stage to fault find) the motion vector warp disappears and the still frame is all that comes out. I’ve tried with flat surfaces, extended bicubics and projections but am getting the same result. The same motion vector pass is doing a great job driving roto in another action.

Any suggestions gratefully received.


Quick update - I tried making the action performing the motion vector warp into a BFX and pre-rendering that and it worked.

Thanks for your patience and I’ll try harder next time.

There are massive basically un-fixable bugs in the MotionVector Tracking code. Not sure what platform you are using, but when MVT starts to go bad, a hardware reboot might help.

1 Like

There are bugs in motion vector tracking but it is too good a feature not to use.

To provide me with some stability and certainty that it won’t change, I will often render out a 32-bit UV map from my motion vector action that I am happy with and use that instead.


There is a handy Python script that will create a UV clip out of you MV’s, based off a selected start frame.

1 Like

Thanks all. As ever, a post to the forum is an enlightening experience. Going to try that UV map next time