Multi channel exr’s not reading the multi channel

I have been having a problem where when I read in multi channel exr into flame it is stripping the extra channels off. I have worked out that the first frame slate doesn’t have the extra channels embedded but the actual picture frames do. Is there an easy fix for this…. Currently on flame 2021.0.0.264

Or can a later version of flame get around it.

Thanks in advance


If you are looking at it on the timeline, then yes, you are losing the other channels. I believe you will have access to them if you drag it into batch. In v2022.1, you will have access to all channels on the timeline, and in bfx, to the best of my knowledge.

I’ve had this. It’s pain the hole. What I normally do is read in and write it out from nuke.

Thanks guys it’s as I suspected looks like an excuse to push for an upgrade



Bring them in minus slate.

1 Like

I can switch the browser to frames but how do you make it a see a sequence after. I faintly remember be able to do this years ago?

For the see proper multichannel Clip best of use inside batch use import node.Its important espicially using like cryptomatte passes.For the see as sequence u can try format specific options to see as individual data or as a sequence. Hopefully i could help

1 Like

Sometimes a vendor will inadvertently place a non-multichannel slate as frame one and everything else is multi channel. Bring in frame two forward and join the frames into a clip.

I know how to switch frames to separate the image sequence but how do you join without the slate after?

1 Like

Copy the shot. Browse the duplicate shot with “Sequence Detection” in “Frames,” and delete the slate frame. Set “Sequence Detection” to “Sequence” and import the duplicate.
This may not work in every single case, but it has for me in the past when a vendor’s slate is different in channels or resolution from the rest of the frames.

Yeah that’s what I do but I sort of remember yeah ago in smoke you could switch to frames highlight everything other than slate then it would bring it in without the slate at the front. But I could have just imagined it lol

could it be a Display Window vs Data Window issue??
double check that, cause depending how the exr was done, could be a conflict there. nuke can have both runing at the same time, but in flame you have to choose one.
Format Options > Image > Pixel Space Window

I’m trying to import Redshift cryptomatte renders and Flame is detecting the multi passes in the import window (the MULTI icon on the thumbnail is present), but when you import the file sequence it comes in as about 8 separate fills and mattes - most of them are just black, others have some barely useful layers, but all of it is not how I expect cryptomattes to behave. Am I doing something wrong?

When I bring the files into batch, none of the clips have the “grey” bit where you’re supposed to plug the node in, they’re all blue/yellow as per a normal imported clip. Files are 32bit, and the 3d guy says AE is seeing them ok as intended. Flame 2021.1 :slight_smile:

Cryptomattes without the selection frame?
Ask your 3D person:
Ensure that the preview layer is enabled and set the cryptomatte level to 3

Thanks for that mate, will pass it on!

I often get given too many inputs but flame only excepts 7 seen here in this image:

The top input is the preview frame. Not used to calculate the mattes but helps you to select. And then 6 inputs that look like 3 front + matte.

You can work without the preview frame. Just pipe in the beauty from your CG render so that you aren’t selecting blind.

I think you can find some bunny example cryptomatte a here for a sanity check.

Thanks Richard, this is all extremely helpful! :pray: