Only 2k or smaller options in Flame Setup / Preview

Any initial thoughts on why Flame Setup on Centos 7.6 only offers approximately 2k or smaller in the Preview options?

I did install 7.6 and DKU 16.1 whilst connected to a 1920x1200 monitor, and now have a 4K monitor. Is there somewhere hard coded that I need to update?


Digging through the organic memory I seem to recall something in the xorg.conf. It changed on 8.2, so I can’t really check.

Are you talking about the VideoPreview token / AJA output, or the resolution of the graphics monitor?

If you are talking about VideoPreview/AJA, what type of AJA card do you have? If it’s a Kona 3G, it has to have the right firmware to support UHD output.

If it’s the graphics monitor, in theory the X server should detect the monitor resolution and adjust to it, as long as you have the right type of connection. In particular, if the monitor is connected via a DVI extender, that interface can only support 2560x1600 maximum, you will need a HDMI / DisplayPort extender to support 3840x2160.

For my Blackmagic Mini Monitor 4K. Lemme guess. I’ll need the far more expensive card?

In theory you should be able to do UHD on that card, although I haven’t tried it myself / not sure if Flame supports it. Could could try re-running the FlameSetup GUI app and selecting the UHD timings, or adding manually to your init.cfg:

VideoPreviewDevice 3840x2160@23976p_free, aja, 1, 3840, 2160, 23976p, freesync
VideoPreviewDevice 3840x2160@24000p_free, aja, 1, 3840, 2160, 24000p, freesync
VideoPreviewDevice 3840x2160@25000p_free, aja, 1, 3840, 2160, 25000p, freesync
VideoPreviewDevice 3840x2160@2997p_free, aja, 1, 3840, 2160, 2997p, freesync
VideoPreviewDevice 3840x2160@3000p_free, aja, 1, 3840, 2160, 3000p, freesync
1 Like

Thanks. I’ll try to manually add. This card does 4K on the Mac side. Musta borked something on the install, as they are not in the Flame Setup app as choices.

You can find all the VideoPreview templates in cfg/sample/init_default.cfg

1 Like

Ah. Perfect. It never dawned on me I could just add them myself. That worked great.

Thank you!