PCoIP won't allow clicking the Desktop GUI on Rocky

Hi all,

Crossing all my fingers that someone else has run into this problem before.

Our Flame machine is a HP Z8, and finally decided to leave CentOS 7 behind after having issues with it and an NFS share, so this week I’ve just wiped it clean, installed Rocky 8.7 from Autodesk’s website along with the DKU, AJA software and Flame itself and it’s all hunky-dory.

However, we have freelancers who need to remote in, for which we use Teradici/HP Anyware/PCoIP/whatever the official name is. I’ve found it to be plenty fiddly in the past but I’m having a new problem with it; I install the graphics agent, register the license, enable the systemctl and I can connect to the machine from another and see the desktop GUI, but I cannot click anything on the top menu bar. I can’t open the applications menu, can’t open the power menu or anything, which means I can’t open or use Flame or any programs.

What’s weird is that I can click the window management button on the bottom menu bar; I can see it slightly dim the background as if it’s working, but obviously there’s no windows so nothing comes up.

Keyboard does work, because I can enter Ctrl+Alt+Delete and the power menu appears (unclickable but can navigate with keyboard). However, the other keyboard shortcuts don’t do anything, namely the Super key opening the Activities screen.

I’m at an absolute loss here, in my experience if Teradici can connect then everything’s normally fine. I’ve considered installing a different desktop environment but don’t feel like that should really matter. Any suggestions welcome.

You need to make sure you are using 23.08 of Teradici. They supposedly fixed that issue after 2 years of me complaining.

Even with this version, often the first time someone logs in you will experience this. Logout via Gnome and then you should be able to log back in and use normally.

If you are still having issues contact Teradici Support and reference the case in the screen shot attached here.

I am using Teradici 23.08! How can I log out if I can’t interact with the Gnome GUI?

Exit the PCoIP session and reconnect.

Client and Agent?

In our install, we are still able to reach the Logout menu, but I do use a 3rd party Gnome extension.


No joy with this

Client and Agent yes.

I installed that extension, and I see the changes on the local attached monitor, but when I connect to PCoIP the Gnome shell still looks the same as before, as if the extension hasn’t been applied. Besides, even if it had been applied, I am unable to interact with the Gnome GUI so I’m not sure it would’ve fixed it?

Do you get the same issue after the remote workstation has been rebooted and you access it with HP Anyware? Do you remember if you used Gnome / Logout option before you got the issue? I have seen something similar and HP Anyware told me to avoid using log out to leave an HP Anyware session: one must use Disconnect. Since I follow this practice all good on my side.

Issue persists through reboots and also now three reinstalls. I have never logged out through Gnome, always disconnected.

I’ve got Teradici support looking into it as well now, will update if a solution comes up.

Make sure to use the case # I shared. This has been going on with them for almost 2 years.

But that is what I am saying. Even when Gnome is broken with Teradici, we can still get to the Logout/Restart menu.

And 2 things you need to understand about Teradici.

  1. It is way shittier than we expect it to be given it is industry standard and has Technical Oscar
  2. There is no better alternative for Linux*

*Parsec is probably the best solution though for Windows and Mac

I see what you’re getting at, a shame the extension tweak just doesn’t seem to get picked up by Teradici

Agreed, in all the years I’ve been supporting Teradici I have never ever had an easy time with it. It is a ridiculously buggy and fallible bit of software.

I have made them aware of your case number.

Maybe you have gnome-classic specified in the pcoip.conf file? Dash-to-Panel definitely works for us both locally and via pcoip.

Oh my god that was it! Thank you so much. A little disappointed in myself for not spotting that honestly!

For the record, the .conf file didn’t have any DE specified in it, in fact it was empty, so PCoIP must’ve been picking Gnome-classic by itself.

Spoke too soon; I’m now having the problem you originally describe in your Teradici case; once a window of any program is open, I then become unable to click anything. Problem persists after a reboot

Yes, but at least now it is loading expected window manager.

I made a YouTube playlist with most/all of my Teradici videos. Might be helpful to watch.

Could you share a link?

Try that. Some of the stuff is old, or esoteric stuff made just for Teradici support.

@ALan Didn’t you move to KDE on Rocky for a while due to issues with Gnome or have you abandoned that approach?

With 23.08, Teradici is actually working relatively reliably, so I abandoned switch windows environments. But I did test both KDE and MATE with success.

1 Like