Remove Pulldown Not Working?

Hey all!

Flame 2022, 2023, either Linux or Mac.

I have a Shutterstock 640x480, 29.97 DF, F1, MPG clip with a standard 3:2 pulldown. Imported into Flame and tried removing pulldown. Flame creates a new 24fps clip but does not remove the pulldown (i.e. mixed frames). I selected the first clean frame, even tried trimming the clip so the first frame is the first clean frame or the first two frames are the pulldown frames … tried reversing field dominance … etc. Nothing works.
I created a new clip with a 3:2 pulldown from some other footage and then tried to remove that pulldown, works as expected.
Removing pulldown from the same MPEG clip works like a charm in After Effects.

Any ideas?

Thanks all!

1 Like

If I’m not mistaken, it’s been a long while, select the first clean frame AFTER the first pair of interlaced frames.

I’ve had strange bugs in the past due to the format tag (like mp4 or mov) I ran the clip through the colourcorrector (or any other node) with no change and the new clip worked bug free. I’ve never seen your issue, but it’s an easy thing to try.

Thx, just tried it but no dice unfortunately.

PS … there is something weird going on with the clip or how Flame is interpreting it. When I deinterlace, I got a sequence of frames that is “jumbled” and out of order every 6-8 frames or so.

Just spitballing, but maybe the clip needs to be 720x486?

Thanks … Tried that and 720x480 but still not working. Also tried exporting it out as a TGA sequence, then bringing it back in … still nope.

Did you try 486? I was only wondering because you said the source was 480. Maybe there’s a horizontal offset happening?

Yeah tried both.

1 Like

I recently had to deal with interlaced clips and 2:3, and ran into some issues that weren’t Flame-related, but due to the chain of custody of the media files. Started with nice high-res Olympics footage, then went through I don’t know how many departments and vendors, but by the time it got to me things were jacked. Things being just slightly resized along the way, etc. I’d first confirm if you’re dealing with original camera sources. Also Sapphire has some good field tools.

It’s an old Shutterstock MPG clip so yeah, it probably went through a few things along the way.
But After Effects removes the pulldown from the clip without any issues, it even auto detects the pulldown sequence so I’m assuming nothing is “wrong” with the clip itself but rather how Flame deals with it.
Hhhmmm … will check Sapphire, didn’t think of that thanks!

repo the original up or down 1 line (pixel) and try again

Thanks … Just tried and still no.

1 Like

Is it identified as F1, F2 or P?

It’s 29.97 DF, F1

The last thing I can think of is changing to F2, although the 1 pixel shift, in essence, does the same thing.


Are you sure that the pulldown sequence is standard? Have you tried with the Advanced or PAL options?
Also, could it be that the clip has a non-sequential pulldown cadence?

Yeah I tried everything I could think of, including Advanced or PAL. Yeah there may be something funky with the cadence.

Could be that the cadence is non-sequential and that After Effects can automatically detect it. Flame doesn’t.