Seeing all the attributes / styles of a font

Hi! How do I access the rest of the styles of a font (like “heavy”) from the Flame font interface? All I can see is the main font family (avinir, next, and condensed).


@La_Flame any ideas?

The Font Book doesn’t really mean that the fonts are accessible by Flame. You’ll need to explicity Export those fonts from Font Book to somewhere on your Mac/network in order to browse them. Its been awhile but if ya need help Im sittin in front of my machine and can screen share with ya if thats helpful.

These are ttc fonts, and according to the release notes Flame has been able to read these font collections since 2021… so we still need to export each style separately in order to read them?

From what I remember, the Font Book is like a pile of fonts. Just because its in the Font Book doesn’t mean that Flame, Photoshop, Word, Text Edi (anything) can read them. Font Book allows you to store and then Install and Uninstall fonts when needed.

And when you install Fonts, theres likely a directory somwhere where they are stored on the Mac, and Mac apps know where they are. So, maybe there is that folder and you can just manually nagivate to it in Flame.

1 Like

Flame views the font, it’s just not showing the individual fonts in the collection. According to the release notes, ttc files are supported. My main question is how do I view the individual fonts in the font collection?

Location: /System/Library/Fonts/Avenir.ttc

Flame can read this. The issue is that it is not showing me the other variations in the collection.

“Better support for fonts.** You ca now load .pfb and .ttc fonts where fonts can be loaded. And if the font browser filter is set to Auto, only a single instance of each font is displayed.”

from release notes What's New in Flame Family 2021 | Flame Products 2021 | Autodesk Knowledge Network

It’s been a while since I’ve had to mess with this, but I’ve only ever seen individual .ttf/.pfb/etc files per font. If you right click on the various font versions in font book and do “show in finder,” does it really point to just Avenir.ttf?

TTC is a True Type Collection that contains a bundle of True Type fonts. The location is here:
Location: /System/Library/Fonts/Avenir.ttc

1 Like

https://transfonter.org/ for the win.

This is NOT a .TTF font.
This is a .TTC font, which Flame is supposed to be able to read but apparently still doesn’t. :slight_smile:

2 Likes

Ah! My bad. Glad you found a tool that fixes it!

1 Like

I have found that for some fonts, I need to set flame to “see hidden files.” Also, I have found that with some fonts, if I change the extention to .font, flame can see it. I have never done this on a mac, however.

Yup - but I had to convert it… I did try the “see hidden files” thing first but it turns out I had to convert it from a .TTC font to a .TTF font. Flame is supposed to be able to read .TTC but apparently it still doesn’t.

1 Like

digitalbanshee –

I don’t have any .ttc files so I can’t check this myself, but based on the quote above, what options other than “Auto” are available in Flame’s Font Browser?

You don’t need .ttc files to see the options in the Font Browser window… :wink:

I am running Flame 2022.3.1 Update (Mac Pro 2019)

TTC is a True Type Collection that contains a bundle of True Type fonts (ttf).

Flame views the base font (Avinir Book) but does not show all the individual fonts in the collection (Light, Medium, Roman, Oblique, Heavy, etc)

I had already tried showing hidden files, as well as selecting all the options in the pulldown menu. (Auto/OpenType/TrueType/CID/Type 1).

According to Flame’s 2021 release notes, .ttc files are supported, but perhaps that just means the single base font is now viewable whereas before it could not read the .ttc file at all?

In any case, I had to unpack it into the individual .ttf files to see all the fonts in the collection.

1 Like