Sequence publish

So, I’m done with the crowd generation/actor duplication spot. I have one timeline with segments of two different color spaces:

  1. Alexa LogC
  2. Phantom Log2 (but tagged as Rec709 on the timeline)
    When I export using sequence publish some Phantom Log2 segments get tagged as Alexa and not as Rec709.
    Their resolutions differ as well. Segments exported properly as Rec709 have the full 4K resolution, while segments exported as Alexa are UHD.
    Alt-clicking the segments on the timeline shows them to be Rec709 yet they are exported as Alexa. Even if I add timeline ColorManagement and tag them it doesn’t matter. I can really force them to Rec709 on the export settings but then all the clips will be exported as such.
    There are manual workarounds for this late in the day but I really would like to know if you encountered such a thing and what causes it…


1 Like

Is anything tagged?

Even if I tag them with timelineFX colour management as rec709 they don’t showup with the correct ColourSpace when exported… I’ll do a bug hunt tomorrow…

1 Like

Okay, so if they are tagged, that is step one. But tagging isn’t an actual transform, it just sets up the Viewing of the clip. In order for it to show up correctly on export, you have to do a gap color management on top of the clip that explicitly says “this is Rec” or “this is LogC” or whatever you have. So, if it looks right in your timeline, but doesn’t look right on your export, its because you are missing this last step of not just a Tag, but “Make it this.”

Add a gap color management above the segment and setup a View Transform that is pertinent to each clip type in your timeline. You know you have it working correctly when you move the Timeline Positioner up and down from the render to the gap color management and it looks identical but it is appropriate tagged in the blue letter’d Viewport thingy right next to Gamma / Exposure / Contrast.

Hi Sinan,

The fact that some Phantom footage is incorrectly tagged when you Sequence Publish is very strange. One thing that I’d want to know is how the footage has been tagged in the first place. If it’s tagged with a color management node in the timeline and you’re doing a Sequence Publish with “Use the Original Media” selected, the Timeline FX (including the color management node) is ignored. If the media was tagged on import or in the Format Options menu, then that should carry through to the Sequence Publish. If that’s not it, maybe find the “problem” Phantom clips in the original timeline you published and confirm that they are tagged correctly beforehand and also confirm you aren’t using the “Use LUT” button when you’re performing the Sequence Publish.

As to the resolution issue, if the media is getting resized based on how it is being tagged, that sounds like a crazy bug. If it’s not a bug, then it could be related to the Use Original Media vs Use Media with FX again. It’s sounding like you used Use Original Media, and the camera source resolutions are different between the Phantom camera and the Alexa camera. There are a handful of variables here, but if you wanted all of the clips to be exported at the same resolution, it would depend on the resolution of the timeline in question, and whether you’re able to Sequence Publish with the Use Media with FX setting enabled. That depends on if the timeline in question is a finished conform or just something like Sources / Shot sequence.

How to proceed from here really depends on what you’re planning to do with Sequence Publish. But I just hope there’s something useful in these two paragraphs above!

1 Like