Silhouette 2024 on 2025.0.1 freezing flame

Anyone else having issues getting Silhouette 2024 to load via OFX? For some reason when I try to launch it, Flame freezes and I have to kill the terminal to get out. I seem to remember it autoloading in flame 2024 and the window just coming up, but I have to select the plug in now like mocha… I can run silhouette as a standalone, just not as an ofx.

Rocky 9.3

I’ve tried installing the plugin and the standalone with dependencies. Not sure what else to do here…

Yes, there was a bug a while ago, where it wouldn’t release some memory or something. But I thought that was fixed. Maybe @marcopaolini can provide insight?

I used to have an issue where I’d have to exit Flame after every time I used an instance of Silhouette in a Batch, otherwise Flame would freeze up. I haven’t had that issue in the last couple of Silhouette releases though. I assume they fixed the memory leak.

It’s the weirdest thing. You hit the Open Silhouette Interface button and it just locks everything down.

I’m working with Boris support on this, but I’ll let you all know what I find out.

We are attempting to reproduce the hang on the same setup. Will report back.

@snacks Can you provide me with the following logs from /Home/.cache/BorisFX/ Silhouette 2024 after the hang occurs: silhouette.log, plugin-flame.log and server-flame.log?

Sure thing. I’ve been working with Victor and he has them as well. Attached. plugin-flame.log is a 0kb file with nothing in it. Here are the other two.

Also having issues with SynthEyes. I get this when I try to launch it:

[root@vxfhost SynthEyes]# ./
Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: ManageChildProcess failed
(t=0.608066) [GFX1-]: glxtest: ManageChildProcess failed

Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: ManageChildProcess failed
(t=0.608066) |[1][GFX1-]: glxtest: X error, error_code=10, request_code=152, minor_code=5 (t=0.608088) [GFX1-]: glxtest: X error, error_code=10, request_code=152, minor_code=5

(SynthEyes:740948): GtkGLExt-CRITICAL **: 14:21:09.451: gtk_widget_set_gl_capability: assertion ‘GDK_IS_GL_CONFIG (glconfig)’ failed

(SynthEyes:740948): Gdk-ERROR *: 14:21:09.452: The program ‘SynthEyes’ received an X Window System error.
This probably reflects a bug in the program.
The error was ‘GLXBadContext’.
(Details: serial 3487 error_code 158 request_code 152 minor_code 6)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
./ line 34: 740948 Trace/breakpoint trap (core dumped) ./SynthEyes $

[root@vxfhost SynthEyes]# [ERROR viaduct::backend::ffi] Missing HTTP status
[ERROR viaduct::backend::ffi] Missing HTTP status
^C (3.3 KB)

This might be a silly question but is there any detriment to using the root user, and the subsequent ownership of files?

I tried both root and user and get the same errors… ugh…

@snacks We can reproduce the issue here with Flame 2025.0.1 running in Rocky 9.3 and are working on a solution. The issue seems to be specific to Rocky 9.3 as Silhouette 2024 runs as expected in both Flame 2024 and 2025 both in Rocky 8.

Thanks, Marco. I appreciate the update and confirmation that I’m not crazy.

Victor has been helping me out with some Syntheyes issues as well. When it rains, it pours.