Strange black outline around shapes

Hey Guys

Ive been getting a very weird, what appears to be an aliasing issue, but not exactly sure.
i have a Red shape on a green background, there is a dark rim that is present around the red shape,
i have had no success, trying to figure out how to sort it out.

ive attached a batch setup, very simple.
Any ideas ? (21.3 KB)


I am on 2021.2 so couldn’t open the batch. But I’m guessing this is expected behaviour due to the nature of comping in rec709 colorspace. If you take your comp into a scenelinear colorspace the edges will look as you expect.

Thanks Sinan,
Will do a quick color management to see if it is the case. (24.7 KB)



Hey Sinan

Yeah its still there and seems to be more prominent, i see you had a 16pxl feather, the shapes actually need to be super crisp and sharp. Are you seeing the outline on your side ? Scene Linear / AcesCG or Rec709 ?


Check your viewing mode on the lower left side of the screen when looking at the output of the action, it should be Linear, if it is Video (on linear) then yes you will see the edges. Check that your view mode on the output of the ColorManagement node is Video and it should look OK.

Welcome to the Hell-hole (or Heaven as some will say) we call color management…

LOL … Yeah sorted it out on my viewer. Now just to get a Rec709 render that does not bring it back. Are we just bound to this outline when rendering out ?

Not Present on my UI monitor but visible on Aja / Blackmagic output to broadcast monitor

You should use a color management node to get your graphics into scenelinear or log, do your comp, convert back to wreck709.
I would strongly suggest you to watch this great video by @andy_dill. He explains a lot of the convoluted comp scenarios in an accesible manner.

1 Like

thank you ! will check it out, difficult to explain to clients whats going on, they sitting in the room …
Im trying to figure it out and they still here, just lingering, waiting for a fix … lol. ill send them back to their natural habitat, food court, whilst i figure this out.

Ah, clients. Another level of management. You could try to bore them to death by explaining the technical limitations of current display systems. Or if there is an art director who knows their stuff, you could literally have an intelligent conversation about additive and subtractive color systems. …or not…

Is there any chance that you can persuade them to choose slightly different colors? I mean, red on green in video is going to blow up in their faces again sometime…

Best of luck @Keno_flo

Could be something simpler, what’s the sharpness setting on the broadcast monitor?
Also, turn off filtering in your viewer. I hate that it’s on by default. I make pixels for a living and it’s ridiculous that you have to jump through hoops just to see pixels that you’re creating.
Lastly, you could look at each channel. If nothing gets unnaturally dark at the transition point, in may just be a display artifact…

1 Like

Thanks Sam, I’ll dig deeper into the color management / sampling / filtering settings. I had to convince client that it was in fact a display artefact created by their colour choice, and proved it by swapping out the colours and walla, no more dark edges, they chose to keep their colours and live with the slight outline.

1 Like

This video is pretty good for clients:

It at least explains they “why” of the issue. Clients being clients, they might come back with “FIX IT,” of course.

To rectify it you’ll need to convert everything to linear and comp it, then convert the comp back to rec.


I had that once. The TV was drawing a dark edge between areas of contrast. I zoomed in till we were looking at about eight pixels to show that it wasn’t in my image. Still unclear if the clients believed me. Haha.

1 Like

looking at the setup, @SamE is the winner here. I shut off filtering (in batch it’s in the “view” tab way on the right) and all the edges lost the issue.

Colorspace only becomes a factor once you’ve got some blending between complimentary pixels. However, with no anti-aliasing any animation of these shapes is going to chatter, so you may still want to go into linear. I’m attaching a still that demos this and a batch setup with options, but to reiterate, Sam had the right answer here, I’m just being a nerd and worrying about the next issue that may come up. Haha. (68.2 KB)


Thanks @SamE @andy_dill , will run through the shots again with this fix :+1:t3: