Teamviewer on Rocky Linux

Anyone had any luck getting Teamviewer into Rocky? I tried and it need dependencies. I tried to install EPEL and update and it breaks Gnome. Any ideas would be great. Basically once I update EPEL and it updated the kernel, it will not load Gnome desktop anymore.

I install teamviewer on every OS reinstall with no problem. Teamviewer has its own repo. You only need the add the new repo and install tw with dnf. It does not update libs or shit like that. You can find a guide in teamviwer’s website. Others apps like sublime or so works in the same way.

About EPEL, it doesn’t have to update the kernel. I used to add repos (epel, el repo, and so) and install a lot of utilities or software, thought I always install everything I need before of install dku and flame. And of course you don’t have NEVER to update (sudo dnf update) the system (did you do it?) . A lot of guides start updating the system. It ruins the OS for dku / flame.

P.S There is a little issue with epel, which update some conf file and showing a fake OS version for the user (and for some app). It’s easy to fix.

I´ll post it tomorrow backing in the office.

Thanks.

I was able to get it working with the info you provided. I dug into TV website and found a simple EPEL installer that worked and I believe I have it running.

I was told a few years back to only install Teamviewer from the DKU. That was a few years back, but I really screwed myself by going rogue. Tagging @fredwarren

The current DKU doesn’t not install TeamViewer in Rocky.

1 Like

Hi @ytf,

We stopped including TeamViewer in the DKU a few years ago.

Users must install it manually.

Best,
Yann

2 Likes

This an alternative way adding its specific repository.

-add new repo creating the .repo file with nano:

sudo nano /etc/yum.repos.d/teamviewer.repo

-copy next lines:

[teamviewer]
name=TeamViewer - \$basearch
baseurl=http://linux.teamviewer.com/yum/stable/main/binary-\$basearch/
gpgkey=http://linux.teamviewer.com/pubkey/currentkey.asc
gpgcheck=1
enabled=1
type=rpm-md

-save and close (ctrl + o , ctrl + x)

-refresh dnf:

sudo dnf repolist

and install:

sudo dnf install teamviewer

And that’s all. If you want disable the tw repo, edit the repo file again, changing enabled=1 by enabled=0

As I said , apps like anydesk, sublime text, and so, use same method.

And if anyone , installing epel repo, or maybe dnf-plugins-core, realizes that info system , neofetch, or any app , shows a fake version number (for instance , Rocky 8.6, rocky 8.7). (There are a lot of people complaining about this)

Check that system was not updated, checking the grub entry on boot and taking note of kernel and version showed, or checking the kernel version with

uname -a

(anyway, if you updated the kernel, you screwed up the system, and probably you may have already noticed :smile:)

kernel version for 8.5 is 4.18.0-348

Info system is taked from two files. To edit them:

sudo nano /etc/centos-release

and

sudo nano /etc/redhat-release

…and change the version.

1 Like

YUM/DNF update often leads to breakage, best to find an alternate solution. The below 3 step process has been used to enable of TeamViewer on Rocky 8.5:

  • Download the TeamViewer rpm
  • sudo dnf install epel-release
  • sudo dnf install teamviewer.x86_64.rpm

I will update the article that Yann linked above to include these Rocky 8.5 instructions.

Just remember to open TeamViewer in the GUI for the first time and accept the EULA. Good luck.

1 Like

For anyone wondering, EPEL = Extra Packages for Enterprise Linux

1 Like