Teradici and Smoke Hotkeys + Spacebar Hotkeys?

Anybody find a solve with the Teradici Hotkeys and Smoke Hotkeys using a zero client where Spacebar + hotkeys don’t work? For example, Spacebar + Control pan in Batch works but only when you hit the Control first. But, I can’t keep the Batch Contexts 1-9 figured out…


With a little help and some new trial and error I’ve figured out the context views.
But, this is for flame hotkeys, I would imagine the issue is with the zeroclinet itself and not the hotkeys setting we use(well one would think).
So seems like if I give the spacebar a quick toggle while still holding down the number key it works.
So I select it like normal, then let up and tap back down on the spacebar with the number key still held down.

For this other person who’s zeroclinet has an updated firmware in relation to the one I use, he said.
“I have BUT its more of a finesse move…First I have spacebar down and then I engage the context # button I want…Its like iI have to slow down the button pushing for it to be recognized”

A staffer with experience at this studio suggested that you had to take the Wacom pen outside of the confines of the tablet surface itself and THEN perform the hot key, which, I admit I was successful in only one out of like…thousands of tries.

It’s nutso out there with all the unique combinations of RGS/Teradici/Zero clients/Software clients/Flame versions. What a nightmare.

1 Like

Have you tried putting your keyboard into Bridge Mode on the Zero Client?


Hey hey

Anyone figured out how to get smoke keys to work with terradici software? my F-keys aren’t working at all. They appear to be mapped correctly, I’m using an HP keyboard and have tried toggling the various keyboard settings but that hasn’t worked either… this seems bonkers…?

1 Like

All good with this? USB Devices bridge mode solved this correct?

For function keys and Teradici, under System Preferences → Keyboard you need to tick “Use F1, F2, etc. keys as standard function keys”, and under “Keyboard → Shortcuts” make sure you the function keys aren’t hijacked by macOS shortcuts. If you are on a MacBook Pro with a Touchbar and an external monitor, the “Use F1, F2…” option may not show up depending on whether the lid of your laptop is open or not: try quitting System Preferences, opening / closing the lid of the laptop and reopening System Preferences, at some point the option should show up.

For using spacebar as a hotkey: if you are using the Graphics Agent, you need to add:


to /etc/pcoip-agent/pcoip-agent.conf



Yup, this is step 1, and then some of these hotkeys, especially PrntScr/ScrLk won’k work on the Mac unless you bridge the keyboard as well.

Fun times.

If you bridge the keyboard (and the Wacom to get pressure sensitivity), better make sure you know where your mouse is if you don’t want to remain prisoner to your Software Client window forever!

Flame is somewhat annoying in that respect, as it treats the keyboard as “just an array of buttons, any combination of which is available for hotkeys”. That likely goes back to the days Flame used to read directly from the keyboard using IrisGL, “window system? what’s that?”

1 Like

Totally. I have one of those little cheapo Logitech bluetooth keyboards/trackpads with the bluetooth dongle thingy. A delightfully tacky yet unrefined solution.

It sounds like you may have solved the issue. I have had great success bridging the keyboard, setting the Wacom area to 100% area in flame prefs or 0% margin whichever it’s called and using the Wacom driver to put all sensitivity to max. Also on occasion I get problems when flame switches the keyboard pref to the wrong keyboard so that’s always good for a check.

In some ways I’m heartened and frustrated to hear others are suffering similar problems. At least it’s not just my incompetence (this time).