Teradici - Track Focus Key Problem (Jumps 2 Layers)

So a minor inconvenience but has become maddening when editing. To move the “hamburger” or focus from one layer on the timeline up or down a track is usually done with the UP ARROW key (smoke) or the PAGE UP (flame). I’m having a problem that when I use the keyboard to move the focus up or down, it jumps 2 layers. Working locally on the CENTOS Flame works fine, remote work from a Windows box using teradici also works fine, but my current setup which is remote from MAC using teradici jumps 2 layers every time.

Things I’ve tried is downgrading the versions of Teradici to older versions, swapping the keyboard shortcut to another key, changing from smoke shortcuts to flame shortcuts, and all end up doing the same “double” jump on the change of focus. I end up using the mouse, but man, does it slow my flow.

Windows version of teradici has a menu option under CONNECTION called USB DEVICES… that allows the teradici to “take control” of specific hardware, like your tablet. Mac version doesn’t seem to have that option. I tried it on the same MacBookPro m1max (which is running awesome btw!) running flame 2023 locally on that mac and there is no problem.

Also for the record I’m running Flame 2021.1 on CentOs using the latest versions of teradici.

Any thoughts?

1 Like

I had this same issue a few months ago. And you’re right, you go to connection - usb devices and then connect the keyboard and it no longer double clicks your keys. I’m using Teradici 22.04.0 on my Mac (running Catalina) and I still have those options. What version of Teradici are you using?

1 Like

I put in a feature request 6 or 7 years ago to have the option to keep focus on the top track regardless of which track you just moved a clip to.

I’ll dig out the entry later so you can add your vote to it!

edit -

its FI-01196

please vote this up - it would be a huge timesaver for anyone that uses the timeline to actually edit!

1 Like

So in order to use USB Bridge mode on Mac you’ll need to disable csrutil in Mac Recovery mode by booting into recovery mode, opening a terminal, and typing either csrutil disable or disable csrutil. A quick Google will help if you need more specific instructions if you’ve yet to have the pleasure, then reinstall the Software Client, grant that app USB permission in a little pop up window that pops up that you’ve never seen before, and then you’ll have access to USB Bridge mode. This is super frustrating because it appears to me that Teragucci doesn’t officially support this workflow because, duh, security issues, but little do they know how important actual hot keys and actual pen pressure sensitivity is to us.

2 Likes

And by the way, you’ll need a second keyboard. Because once you handover your keyboard to the host machine, you won’t be able to use it for your local machine. My favorite is the pick up a little cheapo logitech Bluetooth keyboard/trackpad combination and use that for my local Mac whilst I am USB bridging my local keyboard to my host machine. And never bridge your mouse. If you bridge your mouse, keyboard and tablet? Hahaha. Have fun wrapping your head around that Shrimp Sandwich.

Thanks for this Randy! No way I would’ve known to disable csrutil. Still no luck though. I disabled it in safe mode. Deleted my PCOIP client, reinstalled the latest version. And first flag is that I did not see the new popup you mentioned, about USB permissions. When my flame came up it was still missing the USB DEVICES part of the menu. After doing this 3 times, just in case I did something wrong the first time, all I have still is in the following image:

A couple more things I’ve tried since my original post. I’ve connected a USB keyboard (I was using the wireless LogitechMX), now the USB keyboard is connected to my CalDigit TS4, as well as hard wiring my wireless keyboard to my macbookpro using usbc directly. Still no-go.

Also double checked the security and privacy to make sure PCOIPclient is selected, and it is.

I’m on Monterey 12.4 btw. Any other things I can try? Thanks in advance!

Thanks glennteel, I’ve tried this using all of the PCIOP clients that are compatible with my mac (Monterey 12.4). Currently I’m using the latest, 22.04.2 of teradici. The 21… versions I don’t believe are compatible with Monterey.

Try this as well.

Ok so an update. After many frustrating attempts, trying the posts above USB DEVICES never showed up. Even after disabling SIP, I never even saw the system extension trying to attempt to install in the SYSTEM PREFERENCES/SECURITY window.

But after a bunch of troubleshooting with the amazing engineer at my office (props to you Jerry!), he found an older version that I had not tried to install before, 21.07.3.

And it worked! I now have normal track focus, going up and down one layer at a time.

Unfortunately we still haven’t figured out why USB DEVICES is missing in the CONNECTIONS file menu, but I will update this post when we do. And if anyone needs this version (because i dont think its on the teradici website anymore) let me know and ill pass it on.

Thank you all for your input!

3 Likes