Teradici PCoIP Software Client launches a blank white screen?

Anybody have any troubleshooting tips? Big Sur 11.3.1. Mac Pro 2019. All of a sudden PCoIP Software Client, the current release version, as well as the Beta/Development version, both result in a white frame upon application launch. Identical OS and hardware on a second machine works fine.

Any thoughts on troubleshooting this one aside from an OS reinstall and rebuild?

“white frame upon application launch”, as in before any attempts at connection?

I’d start with removing your preferences:

rm ~/Library/Preferences/com.teradici.PCoIP\ Client\ Connection\ Info.plist
rm ~/Library/Preferences/com.teradici.Teradici\ PCoIP\ Client.plist
rm ~/Library/Preferences/com.teradici.swiftclient.plist
sudo rm /Library/Preferences/com.teradici.PCoIP\ Client\ Connection\ Info.plist

and reboot (since plists are cached by the OS, just removing them may not be sufficient).

1 Like

Also a good place for Teradici discussion is the #discuss-dr channel on the StudioSysAdmins Slack.

1 Like

Yup…a legitimate white frame before any connections are offered.

Followed your procedure. No luck. Even tried copying those files from the machine that was working with no luck. Tried new Mac user. No luck. The StudioSysAdmins Slack…heard of it…invite only right?

Not super clear how one joins these days, but PM me your email and I’ll be happy to send invite.

You can run the app from the command line:


and it might spit out something different on the working vs non working machine that could help?

Also there’s log files in:


and you can increase log verbosity with the “-l 3” (for instance) command line option when you run the application from the command line.