Teradici Screen Res on Mac

Is there some sort of a limitation on the screen res in Teradici software client on mac?

I have an Eizo 4k on both ends but the remote one seems to be maxing out at 3840x2160.

1 Like

Yeah your better off sticking to 1920x1200 or whatever the next size up is.

Blech, that’s not cool.

I mean it’s close at least but I was really hoping for 1 for 1.

1 Like

I think it does go up to 4k using Ultra mode…me thinks…@panisset…am I wrong?

I can get Teradici to go up to a higher res, but I think it depends on the host side computer. Using a cloud flame, I can set desktop resolution in Gnome in the Application/Display Settings/etc menu, and Teradici will update accordingly. Was a game changer when I figured that out. Using way more real estate… If it’s a Linux machine you’re tapping into, I’m not sure.

1 Like

With PCoIP Ultra, I believe the current resolution limit is indeed 3840x2160 aka UHD. A few things to keep im mind:

  • As of the current 22.04 version, Software Client does not support PCoIP Ultra when running on M1: the Ultra codec uses Intel AVX-2 instructions which are not emulated by Rosetta 2, and although Teradici has mentioned they are working on a native Apple Silicon version, for now it’s an Intel only app.
  • Similarly, the Kernel Extension required for Wacom pressure sensitivity is currently Intel only, and will thus only work on Intel CPU Macs (no Rosetta 2 for KEXTs). The release notes seem to claim the kext won’t load at all on Big Sur (Intel) machines, but haven’t tried it myself. Not sure also about Monterey.
  • When you change the size of the Software Client window (or for instance enter / leave full screen), you are sending the equivalent of a “monitor resolution changed” event back to the remote system. The desktop should adjust accordingly, but Flame does not respond to resolution change events and will cause trouble. Make sure Flame is not running when changing the size of your Software Client window.
1 Like

and then there is this ridiculous bug which I reported back in December and it still is un-fixed.

Now that Rocky 8.5 is officially supported in the 22.04 releases, I intend to reopen the case about incorrect DPI setting at UHD resolution that I had tried to open but got closed because I was running on an “unsupported OS”.