Wacom Pen Right clicker not working?

Hello - Have a wacom Pen question. The clicker on the pen doesn’t seem to be working - The piece popped off randomly and I put it back in - clicks in the holes…but it’s odd - it does not seem to be locking in the middle meaning I can’t use the right click option. Has anyone experienced this or is the Pen just reached its end? It’s not one of the newer ones - I don’t know the exact name but the tablet is the PTK-640.

Have you tried putting in the clicker upside down? It looks pretty symmetric and can sometimes be put in the other way round…

Yeah I tried that - it won’t fit that way so it’s definitely in the right way. I’ve put it back in many times before so not sure why this isn’t working all of a sudden

If you can still feel the tactical button pushes from the buttons, then look at the pen and take it apart to see that you can still see the buttons and they are not broken, and then the piece that comes off the little button pushy thingies are still pushing down on the little pads…After you checked the physical pen, also check your setting in System preferences (im on a Mac) and see if maybe some settings got messed up in the process of the button not working…See that you dont have other programs in “Applications”…and make sure you have your pen settings the same too! See how that goes!

I don’t think I’ve ever taken the pen apart before ha… Its sort of hard to see but one of the holes does look a little indented…I use the clicker like crazy for Flame and Resolve so it’s probably just worn out. The company is going to send me a new one but thanks for the help!