Weird Time disparity in Batch?

Not sure whats going on here - but i think its about to cause me a world of pain on this project!

My project is 25fps, and i have been through the timeline taking notes of exact times i want specific animation keyframes. When i am in Batch and trying to navigate to those exact same points in time, the timecode readout on BatchTimeline is using 30fps not 25fps.

I’m pretty certain that means when i render the complicated animations out, they are not going to be syncing up with the material on my timeline.

Anyone else spotted this, and found a solution to get the Batch timeline to use the same time ref as the project?
Screenshot 2022-11-11 at 10.36.00

  • this window should not be going up to 29f - 24 then 00 when in a 25fps project!


Hi @Lightningad,

  • Are you sure your timeline clip is 25fps? I mean, just to make sure. alt-click on the desktop…
  • Is it batchFX or batch? A bit different beasts
  • Did you conform from an edl/xml/aaf and what was the framerate there?
  • Did you create the sequence/clip as 25FPS?
    Timelines can be at different frame rates. You can chamge the frame rate of your timeline by reformatting. But be careful about the edit.

Hi @Sinan

Yes - its definitely 25fps for the timelne and for the project.
Its in Batch, not bfx.
its currently rendering out 24 different render nodes from within the one batch, so will be a while before i can check but the Render list is showing the files as 25fps.

I’m hoping things will all fit ok - but i was more concerned that a timeline view in batch is using a timeframe that i never use.
I work in 25fps all the time. All the source material pulled into this particular batch is 25fps rendered video from the timeline.
I might need to revise the actual keyframes for the next stage (3d animated storybook) based on the rendered outputs…ah well. Thats a problem for next week!


1 Like

With T+click on the input node with the render node selected, you can still force to have the same input/output TC. So you won’t have issues with the Timeline replacements.

Wondering at which exact step the 25 to 30 fps switch is happening. Is the batch generated via connected conform or shots?

No conform… i created the batch using new batch group option.
All video within the batch is from renders created in a different batch in the same project, all at 25fps.

I know I have had this happen and I can’t remember why or how I fixed it, but it didn’t seem that crazy at the time because I work with multiple frame rates on almost every job. I thought there was a thread about it on the forum. Did you conduct a search?

Do you have any borris effects in the pipeline?

I think this is what caused it once for me.

Thanks Tim, I tried a search but nothing looked relevant…but then my search criteria may have been off!

Intriguing…i do have one, but that was added after i posted the question, so it can’t have been the cause in this case.