Accessing Linux through my mac

Hi there,

I have both a Linux and a mac system at home. When my Linux system locks up is there a way I can use the terminal from my mac to get into my Linux system to kill flame. Right now when I get locked out I have to power cycle and I find it irritating and time consuming!

Any tech savvy flamers out there who might have a solution?


you should be able ssh into your linux box and run killall flame, sometimes its a little iffy but works most of the time for me

1 Like

Yeah @Shauna you should be able to open a terminal and type:

ssh root@[machine name]

I use this to kill my flame when it has locked up

If you need a good kill command I have one that I use:

ps -aux | grep /bin/flame

Find the number associated with your flame task and kill

kill -9 [number]


Before doing that it might be worth trying cntl-alt-shift-backspace to reset graphics and pop yourself back to the login screen.

Useful for when, I don’t know, maybe you went a little crazy with motion vectors and forgot to pre-render.

1 Like

Thanks I will try this next time it happens.

1 Like

@kirk So try this first then - cool, thanks for the tip.

1 Like

Also, if you can Alt Tab into the terminal that launched Flame, Control + C in that will kill Flame.

Also, the Flame Service Monitor App has a tab that includes a Kill Flame button.

1 Like

@friendlyape .Thank you.

@randy Sometimes when I’m locked up the alt tab doesn’t work. Can you tell me where I find the Flame Service Monitor on a Linux system? Thanks!

Ah, well, if you can’t Alt Tab then this won’t be helpful. But, I think on Linux its an application you can launch thats right next the Flame Setup application in the Applications/Autodesk. Looks like this.

I’d be more interested in finding out why your machine is locking up so hard. Typically thats a full vram or ram swapping problem.

Do you have a big comp or multiple big comps open when it slowly grinds to a halt?

@randy Well both times it happened I was trying to play back 50/50 blend with the offline. Files are 4448x3096 anamorphic and the clips were cached but not rendered. I got the green play arrow icon but it completely locked me up. I had 4 batches open on the desktop but they were all small batches. And i have 8 sequences open 90/60/30/15 x 2. Does that sound like a full vram or ram swapping problem?

Btw, Problem went away when I rendered the timeline.

Thanks for the input.

One thing to keep in mind is that occasionally the cntl-alt maneuver will leave flame running, so you’ll still have to do one (or several!) of the shell commands described above before you can get it to launch. This is typically when I call engineering.

Check that you don’t have “Selection” selected on your play options. Sometimes if you don’t have any segment selected, but you have “Selection” as the option it might just hang. On second thought you should be able to tab-out in that case…

typing ServiceMonitor into terminal will bring it up on linux :slight_smile:

1 Like

@friendlyape Thank you!