Action flare/light default Z pos

Is there anyway to make lights (which is then connected to a lensflare) sit at 0 Z position in an Action scene and still be visible? I know it’s Z default is 719, but this means if it’s tracked onto an axis node, it’s too far forward on the Z to be correct. Reset the value to zero, and it disappears behind an invisible wall at roughly 400 on the z pos. Anyway around this?
I’ve also tried connecting the camera to the light in order for it to ignore in the scene, no go there either.
Also, apart from comping downstream, is there anyway for the flare to be screened rather than additive in the comp?

Is it something weird to do with your camera clipping plane? I can track a light onto a point in my BG and it will stick there (reset Z pos of light to zero is fine).

Yeah I just did a test like @leowoo and I don’t get any clipping from invisible walls. Admittedly this was an empty batch with only a light in it. Do you have an image surface clipping and can you turn off z-buffer to fix this?

Also I don’t think you can change the lens flare (light) in action to do anything but add. I often pipe just the flare out and apply a little more blur, maybe chroma warp before adding it back but that way you can choose to screen or if you are feeling a little wild, spotlight blend!

Ahhh yeah it may be a clipping plane issue, I’ll check it out next time I’m on the box :+1:

Yeah comping downstream is my go to as well. Would be great for flares to have blending mode options! :slight_smile: