Autodesk Updates & Add-ons portal not working

Just wondering if it is just my account but I am getting that ultra helpful spinning circle of eternal uselessness when I go to the Updates & Add-ons page to try and download the latest version of Flame. It’s been like that the last couple of times I have tried as well.

Is it happening to everyone or just me?!

1 Like

Wasn’t someone in the Discord talking about this this morning?

Ditch Chrome, right?

@marcwellington ?
@ManChicken ?

Yeah something’s broken. Me and Marc both have cases filed on it but haven’t heard anything (and I just tried again and it’s still broken)

Not a Chrome issue in this case as:
A) I’m on Mac and that Chrome issue seems to be MacOS related
B) I don’t have Chrome installed on my Flame system and I can’t download from there.

This has actually happened regularly enough in the past for me to wonder if clicking on the tab will work any time I need to do so. Main version is always fine though which leads me to the question, why not just have it listed in the first tab?

Yeah it’s not browser-related that I can tell, I tried on Firefox and Edge, and I believe Marc was on Safari and Chrome. He was having another/separate issue successfully downloading the DKU with Chrome. But the updates not showing up in your account seems to be more of an Autodesk issue.

I tried them all. I friend that was in Support mentioned my access has been denied due to the conversion of licenses on Nov 1 from Flame Premium to individual services. I am in contact with Holly from Autodesk to see if she can expedite things. So, the download link for the DKU Bob shared with me didn’t work in Chrome, but did in Safari on Mac. I use the Mac for utility and Flame Assist, but can’t get 2022.2 to install on my Linux box, and that is another support ticket.

Okay, let’s do this differently.

First. Something must be broken because I can’t download any software either.

Second. Who needs what? I’ve likely got it all downloaded already. Mac, Linux, DKU…watcha need?

Hi @randy,

The Update and Add-ons section of is currently not accessible.

The problem does not involve the Flame development team, but we will follow up with the team in charge.

The situation reported by @marcwellington is not related to this.


I need linux Flame 2022.2 and Lustre 2022.2 and Lustre Reactor 2022.2 and a version of the DKU 16.2.0 that works with the Z840. The DKU makes the Z840 choppy and hangs occasionally.

1 Like

Thanks for confirming the issue, Yann. Who do we start contacting to help move the fix along?

Aww phooey. I ain’t got Lustre. Sorry Marc.

Want Flame 2022.2 Linux tar?

@marcwellington ! A very generous member of our community has sent me links. Check yo PMs for links to Flame 2022.2 Linux, Lustre 2022.2, Lustre Reactor 2022.2, and DKU 16.2.0.

1 Like


1 Like

Hello Yann,

Hope all is well.
Thanks for the update. As of today 11/08/21 “” is still not working.
Is there an ETA …or should we wait for 2021.3 :slight_smile:


Hi Folks, Just wanted to let you know that we are aware of this issue, and are working with our IT, support crew to get this fixed ASAP. thanks for your patience. Will Harris

1 Like

In the meantime, if you need installers please post post your requests here. I’ll work with the community to scrounge them up. We already have a bunch ready to go.

Hey hey, this appears to have been updated recently. I’m only on mobile…can anyone else confirm?