Can't access network Flame projects after Catalina update

Just updated my Mac to Catalina from Mojave. Flame 2022.1 launches and works OK except it is unable to see projects on my Linux Flame on the same network.

The Linux Flame shows up in the Host Computer menu, like it always has, but when I select it, the project list is empty with the message about clicking the New button to create a project. I clicked New for the hell of it and Flame immediately crashes.

When selecting the Linux Flame, the Mac shell outputs this:
Error scanning for projects: No such file or directory

The log shows this line a few times when that happens:
[warn] 473820608 prjHost.C:1269 04/22/22:16:21:35.410 Could not get last modified time of '/hosts/10.0.1.209/opt/Autodesk/clip': No such file or directory

I’m thinking this is NFS related and something changed in NFS from Mojave to Catalina (I had a couple of NFS automounts at /mnt on the Mac that were forcibly relocated to /Volumes after the upgrade).

I can ping the 10.0.1.209 address just fine and no other network changes have been made during the upgrade. I’ve tried reinstalling Flame and that didn’t help. I’ve also made sure there are several processes with full disk access enabled in the system preferences that relate to flame (although a definitive list of what should be there to make Flame work is something I couldn’t find).

Any ideas? The connection between my Flames has been solid for years under Mojave and I’d hate to have to go back when this seems like some sort of simple-ish config issue.

Perhaps you need to add /hosts to /etc/auto_master? At the bottom of the file if you don’t have an entry add:

/hosts                  -hosts          -nobrowse,resvport
1 Like

OK. That worked. And I found a line very similar to that in my auto_master file from my Mojave installation. Should have checked that first. Thank you!

So, now my issue is that I used to have shares mounted in /mnt to match my Linux box. Worked nicely. Catalina doesn’t allow that, of course, so I’ve switched my shares to mount in /Volumes/mount_name on the Mac. That works. However, that messes up paths between systems.

This is what the path translation feature in Flame’s preferences is supposed to be for, right? I can’t get it to work right.

I’ve set my Source Path to “/mnt/XVI/” and my Destination Path to “/Volumes/XVI/” so that looks to me like it should work. But if I open my project in Flame on Mac that is hosted on the Linux box, I get checkerboards on clips because Flame is still saying the path to the media is “/mnt/XVI/my_clip.mov” Am I just misunderstanding the path translation feature?

If you want to mount your nfs shares on a Mac at /mnt then…

In /etc/ make a file called synthetic.conf (if it doesn’t already exist) and then edit it to add the following line:

mnt System/Volumes/Data/mnt

That will handle mapping /Volumes/mnt to /mnt for where you need it to be for parity with the linux shares. Presuming you would want to automount your nfs mounts on-demand, you can just tell automount to do the heavy lifting. Make a file in /etc/ called auto_mnt and then add the entries there you want mounted under /mnt. An example line might be adding the following:

/System/Volumes/Data/mnt/<nfs share here> - fstype=nfs,intr,soft,nolocks,locallocks,vers=3,rsize=1048576,wsize=1048576,rdirplus,async nfs://<path>/<to>/<nfs share>

And of course replacing the tokens above with your own nfs share info.

Then, we tell auto_master to look for our auto_mnt file by adding the following line at the bottom of /etc/auto_master

/- auto_mnt -nobrowse,hidefromfinder,nosuid

Reboot and you should be good. I think…

1 Like

I deleted my earlier response because I wrote it from memory and it was bungled–ever so slightly so sorry for the double post.

Thanks for this. I think I have things patched up enough now to continue on my Catalina journey.

I was able to get the /mnt directory created at the (synthetic) root again. I wasn’t able to get the automounter to play nice with mounting things automatically, though. So, for now, the shares mount fine if I click on an alias to them in the Finder, so I just symlinked those into /mnt and Flame seems happy with that.

I might pick away at doing it the right/cleaner way at some point but for now I’m up and running and that’s great. Thanks again for your help. :slight_smile:

1 Like

For sure man. This shit is a bit of a jungle but glad you’re up and running.

1 Like