GUI monitor sleeping - Centos 7

Hello. Ever since I installed Centos 7 my GUI monitor (Dell Ultra Sharp) goes to sleep after a few minutes. I’ve searched settings all over the place but can’t seem to find how to disable this. Any thoughts? Thanks.

my dodgy notes say this…

sudo systemctl mask

Hmm. “flame is not in the sudoers file. This incident will be reported.” My IT department is going to write me up.

1 Like

be root

Oh duh. First day on Flame, folks. Command ran, so I’ll just see if it takes a nap again. Thanks Randy.

You should really start planning to upgrade to a newer linux version in the imminent future. Staying on CentOS 7 will make it increasingly hard to deal with situations like this.

These commands have no bearing on monitor sleep, ZERO.

Agreed. Post super bowl, upgrades follow.

I use this in another configuration of ours, not Flame related at all, and on a different version of linux. So it is essentially un-tested on CentOS 7, but it won’t hurt to give it a try.

in /usr/share/X11/xorg.conf.d/

try creating monitorsleep.conf
with the contents

Section "Screen"
    Identifier "Screen"

Section "Monitor"
    Identifier "Monitor"
    Option "DPMS" "false"

Section "ServerLayout"
    Identifier "ServerLayout0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime"     "0"
    Option "BlankTime"   "0"
1 Like

told you my notes were dodgy

Thanks Alan. Will try.

This is much better than my solve. I couldn’t figure out how centos was managing screen blanking for the life of me so I just wrote a script that simulates an f13 press or some other inert key every ~5 mins using xdotool.