HP Anyware and Wacom

Happy New Year!

Sooo… I know there must be a simple answer to this, but I’m definitely scratching my head a bit.
We’re just moving over to HP Anyware from HPZ and I’m trying to get the Wacom to work as expected. I’ve done a bit of a dive through the forum but I’m coming up with lint.

I’m looking to:

a) have pen pressure come through. If I’m in paint for instance, it’s a constant pressure that is quite low. I know I can change the setting in paint, but this isn’t really how it’s supposed to work…

b) have acceleration work. In a non-remote environment this is what allows for fast navigation and interactivity in batch. Zooming in for instance works very well when this is functioning correctly.

We are running Rocky Linux 8.5 and generally our users connect remotely using Mac OS.

Thanks in advance!

1 Like


I’m not sure I understand which part of that thread to look at. For the pen, if I “bridge” it or whatever it’s called now, I can get the pressure sensitivity to work, but then I can’t control the tablet area anymore. @randy Are you able to have both of those features work together in wondrous harmony?

Once you “bridge” then 100% of the device belongs to your host machine. So your local Wacom settings are obsolete/moot. You control via Rocky and or Flame Prefa on the Linux box at Vanity HQ.

Hint. You can do the same thing with your keyboard to get 100% of flame hot keys to work. But once you “give your local keyboard to your remote flame“ You’ll need either a second keyboard attached to your local machine or disconnect your keyboard from USB bridge mode in order to control your local client with your keyboard in front of you.

so… I agree with you in theory… but I find once I bridge it, I have pen pressure but I no longer have any control over my tablet area, meaning that it just uses the whole thing. I’ve noticed this happening when a machine loads the tablet driver preferences from HPZ in some instances instead of loading it from Flame. So when this happens, the Flame preference for Input devices doesn’t seem to have any affect on my tablet. Part of me wonders if some of this is a result of running HPZ Central on this machine before installing Anyware.

Cloud Deployment

FLME-62020: A slight offset might be seen when navigating the application’s user interface remotely using HP Anyware and bridging the Wacom tablet over USB when Input Devices / Tablet Margins setting is set to any value other than 0%.
Workaround: Since there is no Tablet Margins support in HP Anyware, users must set the setting to 0%.

  1. Start a Flame.
  2. Go to Preferences / Input Devices and set Tablet Margins to 0%
    3, Quit the application
  3. Start Flame.
  4. In HP Anyware client, go to Connection / USB Devices… menu and Disconnect the Wacom tablet then Reconnect the tablet
  5. Go back to Flame and select your Project and User Profile.

You should not see cursor offset while using the Wacom tablet.

As a rule of thumb, always connect the Wacom tablet after the application has been launched and you see the startup screen.

1 Like

I’m going to try this as soon as I’m done my client session today. As a point of clarity, I wasn’t experiencing the cursor offset issue in this instance. It was really that changing the tablet margins parameters within the Input Devices menu didn’t seem to have any affect on my tablet. No matter what values I select, its as if my margins were set to 0%. Again… I’m really wondering if HPZ is the culprit here. Maybe if I uninstall that application or try HP Anyware on a different machine we may get a different result…

Thanks again for the response @ALan . So just to be clear, do you work with your tablet margins set to 0% ? Or are you somehow able to change it afterwards? I can make it work at 0% and I get pen pressure and there’s no offset, but in my experience from a speed/performance standpoint as a Flame artist I can move around a lot faster if I set it to something more like 25%.

Do you work at 0% normally?

Locally I work at 5% (default) with Teradici, it is what it is.

Ok cool, fair enough. But even at 5% don’t you have an offset issue?

@randy I’m curious, do you use your full wacom tablet are when you work?

I use the defaults.

I swear though, in my staff days, I used to use Teradici and Wacom with a modified tablet area, where the top of the tablet was mapped much lower.

It worked fine on the workstation cards like 10 years ago…

well yeah, I’ve used them all at some point. An Amulet box paired with a workstation card worked, it works in HP Z Central…by pure magic I think since it doesn’t even require bridging. But it doesn’t seem possible with HP Anyware. Can it be done in Nice DCV? Anyone know? I’ve never tried it.

But wait. You can control the mapping on the remote side, right? That’s what you want, rights?

Yes, I would like to control the mapping. No…you can’t actually do it. I can tell Flame to remap it in the Input Devices menu, and Flame actually does do it, but HP Anyware displays the cursor as though this hasn’t been done which results in the cursor offset issue. So the cursor will now look like it’s over a button but in reality could be miles away.