Keyboard not working correctly

Hi All

Just taken delivery of a new Lenovo P620 running the latest version of Centos and Flame2022.2.
Having keyboard issues with Win and Alt keys not doing what they should. Tried a few things in the ‘Tweak’ menu in Centos which solves things but then after a time the keys stop working again.

Any thoughts?


1 Like

Hmm. Not a Centos 8 user, but, longtime Linux user. In the Linux OS it sometimes reserves the Alt and Windows key for OS level functions which keep Flame from being able to access them.

If memory serves me correctly, it’s likely that the Alt and Windows key (called Meta in Linux, I think) is set to be an OS level Modifier key. Have a look in System Settings / Window Behavior (at least thats what it was in Centos 7) and look for I believe Window Actions where the Alt / Windows keys may be used as Modifiers.

Its something like that.

In regards to “after a time they keys stop working again,” I wonder if you are crashing and/or forcing hard logouts/reboots. Typically, user settings like these are only saved after a successful logout of the user account. I think,.

Hmm. I’m on a P620, Centos 8.2, but haven’t had any keyboard issues I can think of and I don’t think I tweaked many of the Gnome keyboard shortcuts out-of-the-box. I don’t use many Flame/Win key hotkeys inside Flame but do use Alt ones constantly.

1 Like

P620 user here too. The thing is a beast.

A beast it is! Seems to be a big leap in interactive performance with heavy comps compared to our Z8’s.

1 Like

Yeah im getting 12,000MBps on my framestore. Unbelievable.

The Super key (which is often called Meta or Windows key) is set by Gnome to display the Overview. This is not something we have mapped but the default behavior.

User can change the key used to display the overview in Tweaks / Keyboard & Mouse and select Right Super instead of Left Super and there you go!

Have a look here:for more info: Change Activity Overview Keybinding in Gnome

1 Like