My ESC key has stopped working

Hi there,

I brought this up last week in Discord, and thatnks to Sinan, he tried his best to give me some clues, but now I’ve done a fresh 2025 install and I’m still without esc key functionality. I thought that would fix it for sure.

So - I’m running Flame 2025 on a Mac M1 laptop (I know, I know), and it stopped working a few weeks ago on 2023. I thought the 2025 update would fix it for sure, but here we are.

So far I’ve:

  • Reset keyboard shortcuts to factory
  • Created a new user (Smoke Classic)
  • Checked keyboard shortcuts, esc key is marked as expected to enter Action schematic etc)
  • Checked OS keyboard viewer, esc key is functioning as expected
  • Function keys are enabled
  • Tried all english keyboards inside Flame (I’m running a Logic Windows Avid keyboard - not ideal I know, but I never look at the keys so…), not sure if this is creating the problem? When I unplug and use the standard laptop keyboard, still no joy, so this tells me that the keyboard isn’t the problem
  • Last test was to upgrade to 2025

I’m running OSX Monterey. My next step will be upgrade to Sonoma.
Any thoughts?

OMG it’s now working. I’m… not sure what i did to change it?!

Anyway, I thought I might leave this up in case anyone has any theories. Crisis averted!