Other Flames can't see me

Hi friends,

I think I’m just missing something obvious, but all this Quebec wildfire smoke must have given me a case of brain fog… Flame A can see Flame B, C, & D. But B, C, & D can’t see Flame A… or at least they can’t connect to it and browse its projects… What’s your guess? I think this should be an easy one but I’m not seeing it.

I owe 1-6 beers.


quit flame on flame a, then do

systemctl restart autofs nfs

as root and you should be back in business. you may have to do this on all 4 machines.

1 Like

hmm… I get ‘Failed to restart nfs.service: Unit nfs.service not found’.
I should have said this is Rocky and all other systems are CentOS 7.6

I’ll keep digging…

From flame B, what is the output of: /opt/Autodesk/sw/tools/sw_framestore_dump

Does it “see” flame A?

BTW, it is nfs-server.service (Rocky).

Is this a new install?

So when I run sw_framestore_dump on Flame B, it does ‘see’ Flame A, but it’s a bit different than all the other Flames.

All the other flames list their hardware address as their 1gig IP address. Flame A is listed as its 10Gbe IP address.

Also the others all list TCP then 10Gbe IP and on another line, TCP then 1Gbe address.
In this case, Flame A only lists the 1Gbe address.

Are you manually configuring the /opt/Autodesk/sw/cfg/sw_framestore_map file ?

no, I haven’t done that in years I don’t think. Do you think I should?

No, I was just asking if you had manually configured it.

In the /opt/Autodesk/cfg/network.cfg file, the [Interfaces] section, are you specifying anything? If you leave it alone, it will use all active interfaces…

Is this

  1. A new install
  2. Did it just stop working? Did you try restarting nfs-server.service (on flame A) or rebooting flame A?

I’m about to head out of the office for the day. I was asking if it is was a new install since I don’t know which flame / DKU version you are on and if your networking (at the OS level) was already in-place and working.

On flame A, in addition to what was already checked in earlier posts, I would further check:

  • The interfaces are configured correctly (at the OS level) e.g. can ping and sw_ping on the 10Gbe and 1Gbe networks.
  • /etc/auto.master is configured correctly
  • /etc/exports is configured correctly
  • Check the ordering of the interfaces in /opt/Autodesk/cfg/network.cfg
  • However IIRC there might have been an issue with “Multicast” keyword so you can leave that alone – and just make sure that multicast is enabled on the interfaces (at the OS level).

I goggled and found this, which is kind of relevant, tho I don’t agree with everything they have listed: How to configure advanced networking and interfaces in Flame

May be easier to just schedule a call with ADSK Flame tech support?

I’m going to go through all of this. Thanks so much for these great suggestions.
This is more/less a new install btw.

OK Cool. If it is a new-ish install (assuming ADSK Rocky iso and DKU), then you should double check your 1Gbe and 10Gbe interfaces are configured correctly.

You might want to compare to the Centos boxes and make sure you match which interface/network is the “primary” – the 10Gbe or the 1Gbe. If you do: ip route it should show you the default gateway and its interface. I think autodesk uses the OS default gateway for stone+wire.

I know ADSK is still using the network-scripts, so e.g. in the file /etc/sysconfig/network-scripts/ifcfg-ens4f1np0 (your interface name may be different) you can define GATEWAY in the primary interface.

As always, I recommend that you make a backup of the file you are about to edit in case you need to revert back.

For example I would add these lines to the bottom of the ifcfg-interface file using your network numbers:


Then restart networking: systemctl restart network and then systemctl restart adsk_sw

You Cant See Me John Cena GIF by WWE

Sorry @naveen


Thank you.