Rocky Linux DKU Install issue

HP Z840 with Quadro P6000. First time installing Rocky Linux as we’ve been using macs for a few years.

After installing the DKU the system is booting to a black screen with a blinking cursor, init 3 basically. What’s not init 3 is that I can’t type anything to, say, set init 5 to get X11 to do its thing.

Any thoughts what I should look at? The Nvidia driver is shouting at me…

This is the Autodesk Rocky Linux 8.5 distro, latest DKU.

1 Like

Hmm. I’m not familiar with HP z840s but in my experience, any time the machine is hanging after installing the DKU its because something is keeping it from being able to actually install the Nvidia driver, like Secure Boot in the Bios. Any chance Secure Boot is enabled in the Bios? This is likely the case if you bought the machine second hand or it arrived from the factory with a Windows installation.

I had a slightly similar issue on my first install. It failed during NVidia install and somewhere along broke the system badly where it wouldn’t boot anymore.

I ended up installing fresh image, and when I did the DKU I excluded the NVidia driver (in 2023 there is a commendline option to do so), and installed that one manually from the NVidia website. And learned a few details on how to change the startup settings while doing so.

Cost me a day to deal with it, but in the end seemed like the safer way to go. I had some forum messages bookmarked on the process. I can see if I can still find them.

After install the dku, did you some boot messages showing the new nvidia driver installation (“building kernel”?

Maybe, simply the system did not ban correctly the nouveau driver because an error of dku script, rebuilding grub. I had that error. I don’t remember the cause for my system, but I found the mistake cheking out the logs.

To check it out, boot your system, in grub screen, press “e” over the main entry, and chek if you have the “rd.driver.blacklist=nouveau” text appended in "grub_cmdline_linux= " line.

1 Like

In classic Linux fashion, I followed the process again step by step and it worked this time.

I think the issue the last time was that when I booted the Rocky installer it couldn’t see the internet on the NIC port that I plugged into the network on, when I switched NIC to the other built in port it could. I then manually choose the repository. Rebooting with the working NIC port saw the repositories fine. DKU then saw the machine as a Z840 and installed the correct packages, rebooted and all is good.

Now the issue I have is that all the Autodesk license servers appear to be down…

Nice! Glad you got it working. License services are not down… This happens to me every now and then. Download the autodesk licensing service in the manage.Autodesk.com and install that.