Still can't use a different audio monitor path

Hi all - so in getting my black magic ultra studio 4k going I really want the sound to go straight out of the Mac headphones sockets rather than through the black magic. when I set them different I still get this mismatched im turning it off type of dialogue. can this be fixed please?

Use a piece of software called Loopback. This allows you to send audio to multiple devices. I believe this may be a Mac OS limitation. Or, at least something Mac doesn’t do well out of the box.

It’s a flame thing. I have set Bmd for video and core audio for audio and flame gives me that alert. In resolve there is no problem when doing the same thing.

Use Loopback. With Flame currently it’s the only way.

1 Like

So, what you would do is set your BMD as both video and audio.

In loopback, you should see your BMD device as a Source. You’d add your BMD as an Audio Device specifically, I believe. You can then route it to your MacOS audio (headphones), wherever you want, etc…

It looks something like this:

Oh shit! This might help me fix a whole bunch of issues!! How did I not know about this?

1 Like

The handy thing is “Loopback” now becomes a source for all things WebEx, Zoom, Teams, Slack, etc… So it’s a good way to send audio where you want it… Like a virtual mixer of sorts… For example, I’ve got a separate mic, spotify, flame, even teradici running as sources, and audio from all can be piped through whatever “camera” app you might be using. Lots of other uses too.

1 Like

I have been looking for a solution for this for a good while. Was on the verge of buying some kind of audio splitter.
Much appreciated!!!

I paid my 100 bucks and got the software, and it still won’t work. must be doing something wrong…

When you have Flame set up with BMD for both Audio and Video in your config, audio turned on, and can confirm life in the audio bars in flame… (bars + tone for example), you should see life in the bars in loopback…

One thing to also troubleshoot, is loopback monitoring your inputs on the ultrastudio vs. the outputs? I’d noodle with spinning down the options arrow and seeing if you have anything to tick in that zone.

My mixer, for example can route my computer’s output to a pair of input channels that can be seen by loopback if needed. You might see if the BMD device can “bounce” the flame’s stereo output to any pair of input channels… You can also do this the analog way by literally connecting your output channel pair physically to your input channel pair.

1 Like

Another thing to check out, would be to uncheck “mute when capturing” under Flame’s dialog box and see if that allows audio to pass through (even though BMD is set as the audio output)

so ive got audio on the flame - audio meters show it. mute when capturing is off. it works for airplay and iTunes and anything - I can hear it and see the audio meters in loop back. but nothing on the flame one and nothing on the black magic one. I thinks its because the black magic is a source for its inputs- like its a 16 track audio box. im not sure its actually the outputs. anyhow it works for everything apart from flame at the moment

1 Like

So I think the next step would be to see if the blackmagic config app or audio/midi settings in macOS will let you “connect” your BMD Outputs 1/2 to BMD Inputs 1/2 virtually.

If no options for that exists, you can literally connect a pair of xlr cables or 1/4” TRS cables (not familiar with the physical I/O of your BMD) and physically “loop back” the output of your BMD to the input of your BMD. Then you should see life in the BMD meters in the loopback app and route accordingly.

You’ll also likely need to offset the broadcast picture delay in flame to compensate for the slight audio lag of the workaround, but it should work.

Hope that helps!

Thanks for your help. Still don’t see why flame can’t have bmd for video and fire audio for audio.

Agreed. Having it not deny you to have a separate video output and audio output would make this whole square peg round hole exercise moot.

Feature request?

1 Like

I just feel bad that you’ve spent $100 on the app without it working yet. The physical patch solve should definitely work though.

1 Like

So… it’s slightly OT, but over the pandemic we were working remotely using HP Z or Anydesk or whatever and I could always figure out something on the OS level in Linux to get the audio to play through. Now that we’re running 2022.3, it doesn’t seem to work anymore. I think ‘Pulse’ was the option with the most success. Has anyone cracked this nut?

This should work. What do you have in the Flame / Preferences / Audio as a device output?

It here isn’t really an output option.

In the setup program it’s set to BMD.