How to un-knowingly soften your image in one easy step

6 Likes

Not desirable no!

No altering of the resample option in resize alter the effect?

I will have a play when I am at my desk.

Thanks @Alan

Setting your crop to 1920x1080 is redundant since the resize output is already set to 1920 x 1080 and Center/Crop. Without that extra step, there are no issues in the path you have laid out.

The issue is setting custom source crop sizes which is necessary in our workflow. While my example may seem simple, and simple to work around, the bug persists in a dynamic and complex pipeline.

I’m obviously unaware of how your pipeline works, but it seems to me that the simple solution is to not use the input crops if you are only cropping. Setting the output to the desired size and using center/crop (which is actually the only way I’ve ever done it since the advent of the resize node) is just just as easy to do, and in fact can often be set with just a T-click. I don’t consider this a work around, I consider it the logical path.

I must admit, though, there is some really nasty filtering going on when you turn on crop/lock

2 Likes

Try that with a source that is not centered. I used a very simple example to demonstrate the issue.

I guess if is not centred then it is resampling the pixels. Softening would be an undesirable result of that.

Yeah, I get it. It is more intuitive using the input crop. Like i say, I am unaware of your pipeline.

not if you are using whole and even integers. Then there should be no softening. Even in my simple example, using the source crops at all, even in a center/crop scenario results in softening.

@Alan, went through your same steps and I’m getting same issue. I think the Center/Crop is still going through the Lanczos filter. Which I didn’t think it did.

I just tried this and it seemed to get rid of the softness.

Set Free 1920x1080 (like you did)
Then hit Letterbox and change Lanczos to Impulse
Then change Letterbox back to Center/Crop
Then difference matte

Looks good on my end but maybe you’ll have a different result.

The problem occurs when your input crop is set to anything but 100 and you turn on crop/lock output.

@ytf, yeah missed that step. I think I found a way to do it but it is a few more clicks. When I have a few minutes I’ll record and post.

"When I have a few minutes . . . . " I know that drill.

This shows the issue more explicitly and why there is no simple work around.

If you modify the resize as mentioned before changing filter to impulse and not using crop/lock output and manually changing your destination to HD seems to do the trick. But it is a lot of steps.

see part 2.

Good grief didn’t watch. Checking out now.

Yeah that’s a bummer. I use the resize a lot but never use crop/lock output. I always manually type destination so didn’t notice it as much.

Now that I have a minute while my client two time zones away takes hours to review one 15 second spot, and not to be out done in the duel of the demos, I made something that sums it up much more quickly and simply. Despite the fact that I never do what Alan is doing, it is wrong and needs to be addressed. CropLock_Error.mov on Vimeo

3 Likes

Yup…that does it. Thanks for another perspective on the issue. Hope it gets some traction.

2 Likes