Project crashing

Hi everyone. A current project keeps crashing on loading. Seems to be a gmask in one of the batch setups as I’ve tried creating new project and importing this batch setup and same gmask causes error. Any ideas to get around this would be greatly appreciated.
On mac 2021.2.2

I had this myself recently.
First thing to do to stop the project from crashing is to move the batch from off the desktop. That will stop it from trying to load at the start.

Load another project and then use the media hub, project, to copy/move and delete the batch group from of your desktop and save a copy in your library.

Hiya @mike. Darn, that sounds frustrating.

I’ve seen that before only once, in 2022.1 on Linux. Flame was launching but hanging with "…gmask…’ on the loading screen.

I wish I had an answer, but, I did create a temporary project and pulled the Batch Iteration into a new project. Id break it down into chunks…basically, copy the top half first, see if that works. Then, the bottom half…in order to isolate the possible culprit. I was able to move the Batch Iterations into a another project and then I archived those. Then, miraculously, I was able to open the same Batch Iteration with no problems.

Also, does anyone remember how to launch Flame whilst clearing the currently loaded batch with an environment variable? My Google Fu is letting me down.

@panisset
@Gunpowder
@Jack
@daveoy?
@rallymatte
@Brewster
@alanmcseveney
?

Then the solve for the bung gmask is a little trickier.

It depends how much you really need this setup back. Are there any older versions that don’t crash? Therefore only loosing a few hours of work?

Or if you feel like some experimentation:

If you have your setup saved somewhere then make a backup of the .batch file and open the original in a text edito,. You’re looking to select html-style entries that start with image
and end with image
so just remove half of them, hit save (but don’t close the text editor), switch to flame and see if the batch opens. If it opens then obviously the problematic node is in the half that was deleted, so just hit undo in your text editor, halve the selection, save, repeat. You can solve almost any sized setup within 6-7 goes max

1 Like

Thanks Rich. I’d already tried your first suggestion but crashes on that same mask when importing the batch. Will give this text editor mission a go. The gmask is basically a 2 second rebuild but a lot of work gone into the batch setup

Hi Mike,

One way I’ve found to workaround quickly is to create a new Workspace when loading. Then you can wire the contents/sequences and libraries from the primary workspace via the Projects Tab in the Media Hub. After that make sure to save your workspace and try moving the data back using @PlaceYourBetts method (binary search).

Just make sure the last thing you do before attempting to move the setup from the old workspace is to save. That way if it crashes, you get right back to the saved state of the new workspace and you can keep moving forward.

1 Like

I wish you the best of luck.

Let me know if you understand the matrix that is the batch save file.

I’m looking at it but far from understanding it hahaha

heck. post it here.

Or chuck it here
https://dxs.portal.massive.app

I can open it here and see if I can re save it for ya. zip it first.

scene_001_001.batch.zip (6.4 KB)

you mean this Randy?

1 Like

gmask 172 seems to be the culprit

aight keep goin, I gotta install that version of flame real quick.

Wait…@mike…I need the .batch AND the appropriately named subfolder at that same path to load your batch setup.

In other words, see this screen grab…youll need to zip both of those not just the .batch.

sorry Randy - crossed wires (Rich was talking about that text editor so thought you wanted to look at that file) I’ve emailed batch to you

It crashes me too.

Ah. But it loads fine in Flame 2022.1 on Linux.

One sec. Lemme install your version of Flame on Linux.

That’s good news.

yeah thats why I dont necessarily think this is a gmask issue.

Mike are you able to copy/wire into a new project or workspace?

I’ve tried but crashes and when mask 172 is in dialogue?