Remote playback problem

I am working at home with a Mac using an HP Linux workstation located at the office. We use VPN and VNC Viewer software. Everything was working ok until we upgraded Flame 2021 to Flame 2021.2. On this new version, when I hit playback on a clip, the window freezes on the first frame, and when finished playback it shows the last frame, no more playback on the Mac at home. I went to the office and have checked that playback is running perfectly on the Linux machine. The problem occurs on the Mac machine at home. Have tried on other machines with the same result. Have tried JumpDesktop and Apple’s Screen Sharing, with the same result. It appears to be something related to Flame 2021.2 itself. When switching to Flame earlier version 2021, playback is running perfectly at home.
Has anyone had a similar problem or know what may be happening?
Any help is welcome, thank you very much!

Ok, let me reformulate the question!
How you guys connect a Flame remotely? Teamviewer? Or any other software?
Thank you!

1 Like

Tested Amulet Hotkey for a bit a few months ago and it seemed to work fine. You need a setup on each system - at the office and WFH.

I am just wanting to connect and controll my office’s Flame at home. Maybe I’ll go back and use Teamviewer … Let’s see this Amulet, I’ll check it out. Thank you!

RGS remote boost. Damn near perfect.


Agree with cnoellert! If your flame workstation is an HP Z workstation, then all you have to do is download HP ZCentral Remote Boost (also/formerly known as RGS) and its license will be built + installed when you run the remote boost installer. Remote boost sender is “free” on the Z-models. (The receivers are free to use.)

The receiver can be run on linux, windows, mac. You can try the latest version 2020.1.2 but flame users have complained about tablet margins not working in flame – so if you set the margins, then you should try the 2020.0.1 version which doesn’t have the margin issue. However, that version does have the rando CapsLock and Del key toggle issue.

IIRC, starting from 2020.0.1 – has the 48kHz fix built in, so you don’t have to patch it if you’re still using alsa instead of pulse.

IMO, whichever version you use, just double check all of your tablet stuff within flame – as that seems to be what it comes down to.

Also, don’t refer to the Autodesk Flame KB setting up RGS (as that is out of date – it refers to the 7.x version of RGS) . You no longer have to mod the xorg.conf file – zcentral remote boost now runs as a daemon.

OH, and you should leave the flame workstation monitor ON / connected while using Zcentral. If that is not an option, then you need to get those display emulator dongles and plug those into your gfx cards (instead of the monitor cables).

Another alt. is Teradici PCoIP software, but that costs $ annually.


Thank you cnoellert and jarak08 !
We have a HP Z840. Is it eligible for that free license or it is jus for the new Z ones?

It’s definitely eligible as far as I know. For pen pressure on the remote side you’ll want a Linux OS, Ubuntu being our preference.

If you’re not connected on the client side via VPN you’ll need to port-forwards setup on your firewall but your sys admin should be able to help you there.

1 Like

I’m not aware of anyone using TeamViewer or VNC for more than light duty/engineering tasks. It’s not designed nor not good at a 24/7 remote solution.

It’s probably close to an even split of HP’s Z Central Remote Boost (really rolls of the tongue, doesn’t it?) and Teradici. Rarer is the Amulet Hotkey which is an external chassis that uses Teradici gear. It’s more of a Mac solution since Teradici Mac support is only a recent and yet to be released announcement.

RGS is free but like @cnoellert said you’ll need a Linux client for pen pressure sensitivity, or Teradici with its yearly licensing and use the PCoIP Software Client with the tablet in bridge mode to get pen pressure sensitivity.

1 Like

RGS and Teradici are probably the most widely used. I have a lot of experience with Teradici and it works well, and with just the right setup (lots of moving parts) you can get Wacom pressure sensitivity to work from a Mac client to a Flame on Linux. It’s not cheap ($240/year/machine), it’s definitely an “enterprise grade” solution, with an infrastructure for managing access between multiple users and machines, as well as a Gateway functionality which means you don’t need a VPN to access systems remotely. The big missing part is that it doesn’t support remote access to Macs, so you can’t yet integrate all the systems in your facility, but Teradici has said publicly that this is coming later this year (the remote access client runs on Windows, Mac and Linux).

Hi JF!

Starting with 2020.1 (IIRC), HP added in pressure sens. support under windows 10 receiver – it just has the weird tablet margin bug. You just nave to make sure your receiver side has the wacom drivers installed locally.

Actually, one of our freelancers (who is on macOS) said the wacom press.sens. was working fine in flame (2021.2.1).

HP said they would fix this sometime within the next couple releases.
And yes, you do have to be connected to the VPN for RGS use.


Hey Janice!

The other thing that can be tricky with extension solutions is “non standard” key combinations. Flame in particular likes to use all sorts of wacky key combinations as default hotkeys, and not everything gets passed transparently from the remote client to the Flame: sometimes it clashes with local operating system hotkeys, and sometimes it seems that the local client is just arbitrarily deciding that “why wouldn’t anyone want to use this key combination?”.

1 Like

Big Sur and the latest PCoIP dev version, not the release, works great in bridge mode. After a bit of disabling csrutil and some kext stuff I had a lovely experience a couple weeks ago where all the hotkeys via Teradici were solid.

Oh that’s good to know, since the currently released version does say no support for USB bridged mode on Big Sur. Did you have a chance to try out PCoIP Ultra on M1, since that’s not supported as well on current released versions.

1 Like

No M1 devices at my disposal. If I run into an opportunity to test I will report.

Ooh…I just snooped around about PCoIP Ultra…is that new? That’s something at the host level, right?

@panisset Yes, the keyboard hotkeys can always be a source of frustration. We’ve enabled the “Send First Key” in HP Zcentral which seems to help a bit in Flame (if the HP software itself doesn’t have its own key stroke bugs!). I had a user who kept pulling up the local linux virtual consoles – but I think that was because of his cursor placement being outside of the HP rgs window – he was on a linux client.

Did you catch this on the Flame 2022 deprecated software page:

Retiring the dlUS mapping

The Smoke English (US) / dlUS keyboard mapping is no longer required on CentOS 7.6 (KDE) and CentOS 8.2 (GNOME). You can now use the English (US) keyboard mapping and correctly use the keyboard shortcuts in the application.

DL-US: I was never very clear on why that was needed or what it actually did, except that it usually caused problems. Good to know it’s gone.

PCoIP Ultra: it’s basically a newer codec than Tera2 which supports higher resolutions and frame rates. It is not supported by current gen Tera2 hardware solutions (Remote Workstation Card, Zero Client), and requires Intel AVX2 instruction set support on both the workstation and the software client. I’d love to run actual comparisons between “non Ultra” and “Ultra” streams.

Thank you guys for helping. I am feeling so stupid for not knowing about HP ZCentral Remote Boost!
That’s just fantastic! Working just fine here, Flame 2021 Centos 7.4 and using Mac for the remote.
Tablet and keyboard command working almost the same. There’s the tablet pressure issue. Maybe I’ll install Ubunto on my Mac. Have tried to configure ALSA for audio with no success. Flame did not recognize ALSA on my system, but I’ll try to figure out what’s going on later. For me it’s not so important to have audio working all the time, but definitely I’ll need it working!
Thanks, guys!

Even with the Wacom pressure problem it has to be significantly better than Team viewer no?