Tilde key doesn't tilde

God I know Ive answered this question for other people so many times and my mind is blanking…

Linux…tilde key isn’t working…new user made…smoke keyboard layout done…what am I forgetting?

I wish I had an answer but I don’t. Hopefully some one else can chime in because I would love to know.

This happened to me about 9 months ago and the only saving grace was when my company updated the software all was good. But if you have to stay on the same version it would be great to know the workaround.

Main thing is to change to normal is layout then logout and change back.

1 Like

@randy I had this written down:
Tilder key not working Mac ~

Check that your have the correct keyboard selected in preferences.

Tilder key not working Linux ~
Check that your have the correct keyboard layout (basic) selected in the top right menu bar.

2 Likes

Autodesk knowledgemnt database alyways refers to switch to “basic” layout. But I never use it. (In fact , I’ve never seen any “basic” layout in my system). I always use a layout named “dlu”, installed by dku (or flame), and I never have any problem:

2 Likes

So we had done this, but apparently there was something in RGS that wasn’t happy…this solved it.

So, if your tilde key isn’t working in Centos on the Sender machine, be sure to set the keyboard layout as Smoke English. This is a common problem at larger facilities with managed OS installs. And, if you are using RGS with Mac as the receiver of a Centos machine, and the above doesn’t work, try this as well.

If, when using RGS / HP Z Remote Connect from a Mac to a Linux Flame, and your tilde key when you press it actually causes < or > , then follow these instructions:

Your rgreceiverconfig file should be located at /Library/Application Support/HP/rgreceiverconfig

1.Close the receiver

2.Edit the rgreceiverconfig file

3.Add the property Rgreceiver.KeyboardMapMode=1

4.Save it, and restart the Receiver

This worked on Big Sur 11.3.1 when using HP ZCentral Remote Boost Receiver 20.1.0.26348.

1 Like

I am on a similar system setup at home.
I have found this setting in the KDE Control Module and have added the Smoke English (US) layout,
but I am still having keyboard issues.
Mainly the number pad on the right hand side is not functioning properly ( I do have NUM LOC on).

In that same module under layout, what Keyboard Model should I chose? I have tried Generic 104 Key PC as well as unknown and also Logictech all with the same results. Do I need to check any other settings? Any other suggestions?

1 Like

What precisely is the setup you have?

Are you on a flame in front of you? If so, do you know the hardware and CentOS version? Controlling one via Teradici or RGS? If so, what is your local computer/hardware/operating system/keyboard type? And what precisely isn’t working?

Hey Randy,

I’m controlling a Linux Flame over Teradici. It is CenOS 7.
I’m using a Smoke/Linux Logic keyboard.
It just seems quirky: for instance the numeric keyboard on the right hand side does not let me enter numbers into the pop up calculator. A lot of my hot keys don’t seem to work. I have set the keyboard to SMOKE US English and 104-key Autodesk, I have tried numerous other choices with no luck. I’ve had no issues in the past but this is my first go around on 2021.2.1

Weird. Open something not in Flame…like Firefox and log into your email or find a text editor that you can type into with Flame not launched. Do all of your keys work in that? As in, type me up a test email and do the numeric keys work there?

Ok, I’ll try that shortly. Thanks for taking the time.

Ok, I have opened up Gmail and tried to type using the numeric keypad on the right and that does not work either. Typing numbers from the horizontal row works fine. I’m going to switch out keyboards to my iMac keyboard and see if that works.

Also the same issue with the iMac keyboard

Hmm. Are you on Catalina or Big Sur and running the latest Teradici PCoIP Software Client?

Neither. This setup is not through a Mac. I was provided a remote kit consisting of an Amulet Hotkey box and a monitor. Last month for this company I was running the same hardware configuration with no issues but now they have me log in on a Teradici PCoLP software client connection to the Linux box.

In the KDE keyboard settings I have dug deep to check settings. I have selected “Numeric keypad always enters digits” as an option. I have tried all the layout options for “layout of numeric keypad”. Nothing solves the issue. This is a wired one!

Weird not wired!

If you are using a zero client like an Amulet Hotkey and having problems with keyboards then its likely a Linux user problem. Have them make you a new Linux user. If memory serves me right, there’s nothing in the Amulet Hotkey client config that has anything to do with keyboards, just what kind of USB devices they allow in the first place.

Ok thanks Randy. I will ask them for that in the morning. I appreciate you taking time tonight. Hope you are doing well these days.